Closed Bug 1254477 Opened 4 years ago Closed 4 years ago

[Presentation WebAPI] receiver should always return null for the defaultRequest

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla49
blocking-b2g 2.6+
Tracking Status
firefox49 --- fixed
b2g-v2.6 --- fixed

People

(Reporter: schien, Assigned: kershaw)

References

()

Details

(Whiteboard: btpp-backlog [ETA 5/26] [ft:conndevices])

Attachments

(1 file, 1 obsolete file)

According to the latest spec:

A user agent that is a receiving user agent but not a controlling user agent MUST always return null for the defaultRequest attribute. It MUST treat setting the defaultRequest attribute as a no-op.
We can either check the 'mReceiver' in Presentation object or use the role introduced in bug 1234492.
Whiteboard: btpp-backlog
blocking-b2g: --- → 2.6?
blocking-b2g: 2.6? → 2.6+
Whiteboard: btpp-backlog → btpp-backlog [ETA 5/26]
Attached patch Return null for defaultRequest (obsolete) — Splinter Review
Assignee: nobody → kechang
Attachment #8756718 - Flags: review?(bugs)
Comment on attachment 8756718 [details] [diff] [review]
Return null for defaultRequest

I think the spec should be clearer about what happens when the attribute is set on receiving side. Like mention that the operation is no-op.
Attachment #8756718 - Flags: review?(bugs) → review+
(In reply to Olli Pettay [:smaug] from comment #3)
> Comment on attachment 8756718 [details] [diff] [review]
> Return null for defaultRequest
> 
> I think the spec should be clearer about what happens when the attribute is
> set on receiving side. Like mention that the operation is no-op.

Thanks for reviewing.

As comment #0 said, the spec do mention this.
Attachment #8756718 - Attachment is obsolete: true
Attachment #8756894 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d4a5ef2ca595
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
Attachment #8756894 - Flags: approval-mozilla-b2g48?
Josh, please help to approve. Thanks.

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Presentation API
User impact if declined: The behavior of presentation defaultRequest cannot be aligned with spec.
Testing completed: with automation test
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: n/a
Flags: needinfo?(jocheng)
Whiteboard: btpp-backlog [ETA 5/26] → btpp-backlog [ETA 5/26] [ft:conndevices]
Comment on attachment 8756894 [details] [diff] [review]
Return null for defaultRequest, r=smaug

Approve for TV 2.6
Flags: needinfo?(jocheng)
Attachment #8756894 - Flags: approval-mozilla-b2g48? → approval-mozilla-b2g48+
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.