If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Test that link clickers on Firefox e10s browsers who click links they generated themselves don't encounter issues

RESOLVED WORKSFORME

Status

Hello (Loop)
Client
P1
normal
Rank:
9
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: RT, Unassigned)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: [btpp-followup-2016-03-16])

User Story

Happens using Nightly 48.0a1 with Beta add-on 1.2.0alpha and clicker on Chrome.
STR:
1 Create room and copy the URL
2 Join clicker on the same browser as where the room was created
3 See that the generator has no infobar and the clicker has the remote party full screen when the shared content should be there

Issue: there is a back-door from the link clicker side allowing e10s browser users to enter a room. We need to test that this is not causing issues on 1.2 when e10s is supported by Hello.

Attachments

(2 attachments)

Comment hidden (empty)
(Reporter)

Updated

2 years ago
User Story: (updated)
(Reporter)

Comment 1

2 years ago
Created attachment 8728068 [details]
Capture d’écran 2016-03-08 à 12.57.46.png
(Reporter)

Comment 2

2 years ago
Created attachment 8728070 [details]
Capture d’écran 2016-03-08 à 12.57.57.png
(Reporter)

Comment 3

2 years ago
I get the following from the browser console which makes it look like the e10s panel (prompt user to open a non e10s window) is missing?

OpenGL compositor Initialized Succesfully.
Version: 2.1 INTEL-10.6.31
Vendor: Intel
Renderer: Intel(R) Iris(TM) Graphics 6100
FBO Texture Target: TEXTURE_2D
No stores registered for event type  metricsLogJoinRoom dispatcher.js:88:9
Loop:Error: Tab sharing is not supported for e10s-enabled browsers
Stack trace:
kMessageHandlers.AddBrowserSharingListener@chrome://loop/content/modules/MozLoopAPI.jsm:176:17
LoopAPIInternal.handleMessage@chrome://loop/content/modules/MozLoopAPI.jsm:1174:5
MessageListener.prototype.callListeners@resource://gre/modules/RemotePageManager.jsm:35:9
RemotePages.prototype.portMessageReceived@resource://gre/modules/RemotePageManager.jsm:108:5
MessageListener.prototype.callListeners@resource://gre/modules/RemotePageManager.jsm:35:9
ChromeMessagePort.prototype.message@resource://gre/modules/RemotePageManager.jsm:340:3
 MozLoopAPI.jsm:177
Error getting the windowId: Tab sharing is not supported for e10s-enabled browsers activeRoomStore.js:903:9
ActiveRoomStore<._handleSwitchBrowserShare() activeRoomStore.js:903
(Async: promise callback) ActiveRoomStore<.startBrowserShare() activeRoomStore.js:980
Dispatcher.prototype._dispatchNextAction/<() dispatcher.js:100
Dispatcher.prototype._dispatchNextAction() dispatcher.js:98
Dispatcher.prototype._dispatchNextAction() dispatcher.js:107
Dispatcher.prototype.dispatch() dispatcher.js:72
OTSdkDriver.prototype._onSessionConnectionCompleted() otSdkDriver.js:380
eventing/self.once/handleThisOnce() sdk.js:766
executeListenersAsyncronously/</<() sdk.js:999
[12]</callbacks.callAsync/<() sdk.js:1371
(Async: setTimeout handler) [12]</callbacks.callAsync() sdk.js:1370
executeListenersAsyncronously/<() sdk.js:995
executeListenersAsyncronously() sdk.js:988
browserEventing/api.dispatchEvent() sdk.js:1105
eventing/self.dispatchEvent() sdk.js:803
[209]</SessionHandle.Session/connectMessenger/<() sdk.js:35628
onConnectComplete() sdk.js:26932
RaptorSocket/this.connect/</</<() sdk.js:27143
[163]</Dispatcher.prototype.triggerCallback() sdk.js:26271
SessionDispatcher/<() sdk.js:27496
executeListenersSyncronously/<() sdk.js:1040
executeListenersSyncronously() sdk.js:1039
browserEventing/api.trigger() sdk.js:1116
eventing/self.trigger() sdk.js:832
[163]</Dispatcher.prototype.dispatchSession() sdk.js:26355
[163]</Dispatcher.prototype.dispatch() sdk.js:26314
webSocketReceivedMessage() sdk.js:28780
NativeSocket/webSocket.onmessage() sdk.js:28009
(Async: EventHandlerNonNull) NativeSocket() sdk.js:27994
[179]</RumorSocket/connect() sdk.js:28819
[179]</RumorSocket/rumorSocket.connect() sdk.js:28862
RaptorSocket/this.connect() sdk.js:27063
[209]</SessionHandle.Session/connectMessenger() sdk.js:35586
[209]</SessionHandle.Session/onSessionInfoResponse<() sdk.js:35686
tryCatcher() sdk.js:11194

OpenGL compositor Initialized Succesfully.
Version: 2.1 INTEL-10.6.31
Vendor: Intel
Renderer: Intel(R) Iris(TM) Graphics 6100
FBO Texture Target: TEXTURE_2D
I suspect that RT's guess is correct.  Presumably this is not reliably reproducible, given the steps RT listed are what users do every single time they use product, so I suspect our best bet is speculate that this will go away after the e10s work is done, which is arguably embodied by bug 1252621.
Rank: 16
Depends on: 1252621
Priority: -- → P1
Whiteboard: [btpp-followup-2016-03-16]
(Reporter)

Updated

2 years ago
User Story: (updated)
(Reporter)

Updated

2 years ago
Rank: 16 → 19
Summary: No infobar appears desktop client side and link clicker does not see shared content → Test that link clickers on Firefox e10s browsers who click links they generated themselves don't encounter issues

Updated

2 years ago
tracking-e10s: --- → +
(Reporter)

Updated

2 years ago
Rank: 19 → 9
Depends on: 1258335
(Reporter)

Comment 5

2 years ago
Retest and close
Flags: needinfo?(rtestard)
(Reporter)

Comment 6

2 years ago
I am closing since I cannot reproduce this anymore.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(rtestard)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.