Bug to collect user comments on HTTPS test stream using the HLS.js player.

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: richard, Unassigned, NeedInfo)

Tracking

(Depends on: 2 bugs)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Please leave a comment below if you had problems watching the test stream.

Please report browser, version, O/S, and how & where you are connected. (e.g. wired ethernet in the office, Office WiFi, home WiFi, etc.)
Firefox 46.0a2 on Ubuntu 14.04 Linux, Wifi at home connected to 80Mbps cable connection. Stream is good generally. 

* If I speed up to 1.5x, that seems to take the buffering algorithm by surprise; it reaches the end without having downloaded the next chunk. We should either get the buffering to understand the speed control, or disable the speed control (which doesn't make so much sense for livestreaming). 

* The link to pop out the stream in a new window does do that, but it doesn't pause the old stream embedded in the web page, so you end up with two copies playing, out of sync with each other. And when you close the popup, the "Close the popup and restore the video here" text doesn't disappear. Clicking it does make it disappear.

Gerv
Firefox 48 on Ubuntu 15.04, WiFi at home 10Mbps.

Works fairly well, but sometimes it stops with "Video can't be played because the file is corrupt." and I have to reload the page.
I'm not sure if it is the stream or source material but the audio sounds a little clipped or has some distortion in the background. The video looks smooth though and other than the distortion the audio is fine.

Firefox Nightly, latest OSX, home wifi on Verizon FiOS 50Mbps
Firefox 48 on OS X, WiFi w/ 100 Mbps, works great for the past 15 minutes.
(Reporter)

Comment 5

3 years ago
(In reply to Gervase Markham [:gerv] from comment #1)
> Firefox 46.0a2 on Ubuntu 14.04 Linux, Wifi at home connected to 80Mbps cable
> connection. Stream is good generally. 
> 
> * If I speed up to 1.5x, that seems to take the buffering algorithm by
> surprise; it reaches the end without having downloaded the next chunk. We
> should either get the buffering to understand the speed control, or disable
> the speed control (which doesn't make so much sense for livestreaming). 
> 
> * The link to pop out the stream in a new window does do that, but it
> doesn't pause the old stream embedded in the web page, so you end up with
> two copies playing, out of sync with each other. And when you close the
> popup, the "Close the popup and restore the video here" text doesn't
> disappear. Clicking it does make it disappear.
> 
> Gerv

Thanks Gerv,  I've noticed both of those issues.  We're planning to take the speed control off live streams. I don't understand the pop-out problem but I can confirm it does that consistently.  Peter is on paternity leave right now, but he'll be on that one it as soon as he returns.
Hey it works in Safari! YAY! 

The video visual was going in and out. Sound was stable. Now seemed to settle down and works. Ah, actually video disappeared again. It's there, and then it disappears.
(In reply to Dave Townsend [:mossop] from comment #3)
> I'm not sure if it is the stream or source material but the audio sounds a
> little clipped or has some distortion in the background. The video looks
> smooth though and other than the distortion the audio is fine.

Ok it switched to a different video and the audio issues went away so probably just a problem with that video.
(Reporter)

Comment 8

3 years ago
(In reply to Marco Castelluccio [:marco] from comment #2)
> Firefox 48 on Ubuntu 15.04, WiFi at home 10Mbps.
> 
> Works fairly well, but sometimes it stops with "Video can't be played
> because the file is corrupt." and I have to reload the page.

Marco, which city are you watching from?
(In reply to Richard A Milewski[:richard] from comment #8)
> Marco, which city are you watching from?

London.
Worked great for me! I'm a remote user in the UK on a Windows 10 machine. Great audio and video and connected quickly without waiting around.
(Reporter)

Comment 11

3 years ago
(In reply to Marco Castelluccio [:marco] from comment #9)
> (In reply to Richard A Milewski[:richard] from comment #8)
> > Marco, which city are you watching from?
> 
> London.

Can you give FF Dev Edition (FF 46) a try and see if it has the same issue?  Thanks!
In New York. Firefox Dev 46.0a2 on Mac OSX 10.10.3 – everything worked well. Crisp and clear. 

Chrome Version 48.0.2564.116 (64-bit) on Mac OSX 10.10.3 – Video did not start. No spinner. Time slider shows about 25% loaded, but clock sits at 0:00. Pause/Play has no effect.
20min in the stream: no issue whatsoever even at various speeds. Fx45.0 on Ubuntu, FiOS from Sarasota, Florida.

Comment 14

3 years ago
Firefox 44.0.2 on Windows 10, in Waterloo, ON, Canada

Looks good, seems to be working well. 

But, wow, that purple cursor at the top-left is distracting!
I had some audio crackles for about 20 seconds when I connected for the first time (some green screen like a circuitboard, ISTR?), but it was hard to say if it was that video or the streaming system. It's been fine since.

Gerv

Comment 16

3 years ago
Firefox 45, Mac OS X 10.11.3, connected to internet via Time Warner Cable 300 Mbps down. Wired ethernet.

One of the clips (had a lot of electronic music, history of Firefox) had very bad audio clipping.
Firefox 45 on OS X, wired at the Paris office.

Some videos are in lovely HQ, others seemed to be at much lower bitrates; these lower-quality videos looked and sounded terrible, and some had audio "pops".

There was a cursor visible in every video.  I kept trying to manipulate it.  This did nothing.

Also, 0.5x is some trippy shit and should come with a trigger warning.
Works fairly good. Stayed there for ~10mins. Some audio clipping in first video (story of mozilla) but I do not think it has anything to do with your service since video was running smoothly and rest of the videos were fine. City: Athens (Greece) Ver: Gecko/20100101 Firefox/48.0
Confirm it doesn't work on Chromium; looking at the dev tools, there are 2 404s which may or may not be relevant:

GET https://air.allizom.org/nomad-1-public-https-test-hls-js/%3Cfunction%20poster_url%20at%200x7f8317503c80%3E 404 (OK)
%3Cfunction%20poster_url%20at%200x7f8317503c80%3E:1 

GET https://air.allizom.org/nomad-1-public-https-test-hls-js/%3Cfunction%20poster_url%20at%200x7f8317503c80%3E 404 (OK)

But then it does say "manifest loaded, found 4 quality levels", so <shrug>.

Gerv
Yep, I think the audio problems must be the videos rather than the streaming. I hear them in the Story of Mozilla (running now) too.

Gerv

Comment 21

3 years ago
About me: Firefox 45.0, 2014 macbook pro, MTV, Mozilla Guest network, 
Video Quality is good for me on my 
Audio is crackling slightly intermittently
(In reply to Richard A Milewski[:richard] from comment #11)
> (In reply to Marco Castelluccio [:marco] from comment #9)
> > (In reply to Richard A Milewski[:richard] from comment #8)
> > > Marco, which city are you watching from?
> > 
> > London.
> 
> Can you give FF Dev Edition (FF 46) a try and see if it has the same issue? 
> Thanks!

It's been working well for the past 15 minutes in Firefox 48, maybe it was just an intermittent issue.

A thing that I've noticed is that if you seek to the end of the seekbar (by dragging the indicator), a loading throbber appears and never goes away until you seek to another point of the video. Also, while the throbber is shown, the length of the video stays the same until you pause/play.

Comment 23

3 years ago
In Colorado and I am not seeing anything and there is no sound. Black screen. I am about to test the internet speed since I am not at home. Speed Test says internet is pretty slow. Download speed 4.80mbps - Upload 10.05 Mbps.

I am using Chrome.
Firefox 44.0.2 on my Android 5.0.1 tablet just gives the loading spinner; no video :-( I can get on and off the stream quickly on the desktop, so it's not just that the capacity is maxed out now. 

Gerv
connected using fresh nightly on Windows 10 @ 0915PST - 0925PST

no issues noted.
(Reporter)

Comment 26

3 years ago
(In reply to Chris H-C :chutten from comment #14)
> Firefox 44.0.2 on Windows 10, in Waterloo, ON, Canada
> 
> Looks good, seems to be working well. 
> 
> But, wow, that purple cursor at the top-left is distracting!

Chris,

I agree that purple cursor is really aggravating.  But it's just an artifact of using a headless Mac Mini as the signal source into the encoder (instead of the cameras and video switcher).  All of the "hide the cursor" OS X apps seem to fail when the output is connected to a video scaler instead of a monitor.
On Android (config as above), it seems to be loading and buffering the data, as the max time keeps increasing in chunks. But it never displays it. Nothing I do to kick it (speed, full screen etc.) seems to get the video to display.

Gerv

Comment 28

3 years ago
Firefox 45, Sony vaio, Windows 10, Time Warner Cable Modem

After 10-15 minutes, the video froze.

When I reloaded the page, I had no sound.

Comment 29

3 years ago
I've tried to view in Firefox, as well. Still have a black screen but at least there is the scrub bar at the bottom.

Comment 30

3 years ago
Safari 9.0.3 on El Capitan from home 60MB cable modem..

Was streaming great for 10 minutes. Froze up one after 10 minutes of perfect streaming.  Refreshed browser and stream resumed, although showing a new video now..

Comment 31

3 years ago
Windows 10, lenovo thinkpad x1 carbon, 4-6 tabs open (slack, email, gdocs, etc), on Firefox 45. Streamed from 9:07AM - 9:35

Upon click, the stream started instantly. Playback was smooth with no pauses or interruptions the entire time. Video quality was good and remained consistent throughout entire time. Safe to say I had no issues at all.

Comment 32

3 years ago
Firefox 44/45 (upgraded partway through), OS X 10.11.3, Portland Office

Watchable (but by no means "good") quality (in terms of compression. No stuttering) from 9:10-9:22, and then the stream became what I would consider to be an acceptable baseline of resolution.
Firefox 45.0 on a Windows 10 Microsoft Surface using office WiFi.

Watched for 5 minutes. It seemed excellent except that the audio was a bit crackly.
Looking good on Firefox 45.0 (OS X 10.10.5, hotel in palo alto)
Also great and very snappy/smooth feeling on Nightly.
(Reporter)

Comment 35

3 years ago
(In reply to amooiman from comment #32)
> Firefox 44/45 (upgraded partway through), OS X 10.11.3, Portland Office
> 
> Watchable (but by no means "good") quality (in terms of compression. No
> stuttering) from 9:10-9:22, and then the stream became what I would consider
> to be an acceptable baseline of resolution.

That sounds like you were on one of the lower bandwidth streams for a while.  This is an adaptive bitrate stream.  The player chooses between 160p, 240p, 360p and 720p based on available bandwidth and some other black magic.      Office WiFI or wired ether net connection?
(Reporter)

Comment 36

3 years ago
(In reply to Daniel Maher [:phrawzty] from comment #17)
> Firefox 45 on OS X, wired at the Paris office.
> 
> Some videos are in lovely HQ, others seemed to be at much lower bitrates;
> these lower-quality videos looked and sounded terrible, and some had audio
> "pops".
> 
> There was a cursor visible in every video.  I kept trying to manipulate it. 
> This did nothing.
> 
> Also, 0.5x is some trippy shit and should come with a trigger warning.

Phrawzty, -- The speed control is coming off the player for live streams when I can get a bit of a webdev's time.    That cursor drives me nutz!  See comment 26
Windows 10 Pro
Firefox 45.0
Location: Barcelona Spain

Streaming from Air Mozilla for 50 mins.
Very satisfactory audio and video stream

(Usually I cannot watch Air Mozilla live as it crashes every minute or so. I usually have to watch the recording later)
Nightly 48.0a2 OS X 10.10.5, on wireless in MTV office.

Had no audio, mostly. Video regularly stopped for long periods. While playing video quality was good.
(Take this with a grain of salt, since I've recently been having odd issues with OSX, and I'm probably going to try a clean install of OSX to see if that fixes it).
had buffering problems at: 9:39, 9:32, 9:33, 9:36, 9:37, 9:39, 9:42A PST last approximately 10 seconds each, no equivalent ICMP loss at those times.
DevEdition 46.0a2 OS X 10.11.3 on wireless home with cable 50MB Comcast cable uplink

Looked good and sounded good to me. I also heard the cracking sounds in the beginning and then again when the Mozilla history video came up again after 15min or so. So it's probably the sound in the particular video rather then the stream itself.
(In reply to Gervase Markham [:gerv] from comment #24)
> Firefox 44.0.2 on my Android 5.0.1 tablet just gives the loading spinner; no
> video :-(
(In reply to Gervase Markham [:gerv] from comment #27)
> On Android (config as above), it seems to be loading and buffering the data,
> [...] But it never displays it.

Firefox Nightly on my Android phone played the stream just fine, FWIW.

Comment 42

3 years ago
Firefox  44, OSX 10.10.5, home WiFi (Sonic in SF)
Audio/video quality was fine for 11:40min when it froze. Refreshed, and videos restarted; froze again after 1:48min. Moved the scrubber back and videos resumed, but didn't advance beyond the 1:48 mark.

Chrome 48.0.2564.116 (64-bit)
No video. Slider shows up and loads about a third, but nothing plays (stuck at 0:00); play/pause button has no effect.

Opera 35 (because why not?)
Video quality is fine for the first 2 min. Audio is VERY distorted -- music in the background still plays, but the spoken word is extremely slowed down and creepy. After 2 minutes, the video stops and the video window splits with the top half black, bottom half white. Slider still there, but nothing is loaded and stuck at 0:00. Play/pause button has no effect.
(Reporter)

Comment 43

3 years ago
(In reply to James Barnell [:jbarnell] from comment #39)
> had buffering problems at: 9:39, 9:32, 9:33, 9:36, 9:37, 9:39, 9:42A PST
> last approximately 10 seconds each, no equivalent ICMP loss at those times.

OS? Browser Version?  Connection type?   SFO Office?
Flags: needinfo?(jbarnell)
Reporting in from Firefox Nightly on Windows 10 using office Ethernet.

Everything I tried worked perfectly, except the already reported issue with the pop-out button leaving the stream in the main window alone. Quality was good throughout. Usually watching an AirMo livestream for an hour would require me to refresh the page a good half dozen times to try to revive a broken stream, but this one was totally stable.
(Reporter)

Comment 45

3 years ago
(In reply to melissa from comment #42)
> Firefox  44, OSX 10.10.5, home WiFi (Sonic in SF)
> Audio/video quality was fine for 11:40min when it froze. Refreshed, and
> videos restarted; froze again after 1:48min. Moved the scrubber back and
> videos resumed, but didn't advance beyond the 1:48 mark.
> 
> Chrome 48.0.2564.116 (64-bit)
> No video. Slider shows up and loads about a third, but nothing plays (stuck
> at 0:00); play/pause button has no effect.
> 
> Opera 35 (because why not?)
> Video quality is fine for the first 2 min. Audio is VERY distorted -- music
> in the background still plays, but the spoken word is extremely slowed down
> and creepy. After 2 minutes, the video stops and the video window splits
> with the top half black, bottom half white. Slider still there, but nothing
> is loaded and stuck at 0:00. Play/pause button has no effect.

Those audio problems in Opera are utterly bizarre.... but I reproduced them on my machine. (OSX - wired ethernet in MTV) Thanks!
(Reporter)

Comment 46

3 years ago
(In reply to Gervase Markham [:gerv] from comment #19)
> Confirm it doesn't work on Chromium; looking at the dev tools, there are 2
> 404s which may or may not be relevant:
> 

Gerv,

Those 404s are attempts to fetch the poster image that comes up before the video starts.  This test on the staging server and there's some experimental code there to use the thumbnail image selected for the event as the poster.  That code seems to work on the dev server, but not the staging server.  Peter will dig into that one when the gets back.

I'm able to confirm most of the reported Chromium and Opera problems reported here.
I streamed this video for 1 hour.
I saw brief (2-3 second) buffering issue about 20 minutes in.
Then at about 40 minutes in, there was a significant disruption that lasted about 30 seconds.
During that time I could hear audio but the video was just black.
However, the video stream then recovered.

So, not perfect, but not horrible either.
HTHs.
(Reporter)

Comment 48

3 years ago
Looking at developer tool in Chromium it's fetching playlist.m3u8 and chunklist.m3u8 but not the media setments (mp2ts chunks).

Interesting and it smells like a javascript problem.
(Reporter)

Comment 49

3 years ago
Created attachment 8729111 [details]
Akamai Graph of Stream Connections for this test.

Connection Graph snapshot at 10:40 AM Pacific (18:40 UTC).
It works on Android, yay! \o/

Tried in Firefox 46 on Mac, Firefox 46 on Linux, and Firefox Mobile 47 on Android.
On all three, the audio sounds like it's clipping.  Everything seems to be working otherwise though.
(Reporter)

Comment 51

3 years ago
(In reply to Gervase Markham [:gerv] from comment #19)
> Confirm it doesn't work on Chromium; looking at the dev tools, there are 2
> 404s which may or may not be relevant:
> 
> GET
> https://air.allizom.org/nomad-1-public-https-test-hls-js/
> %3Cfunction%20poster_url%20at%200x7f8317503c80%3E 404 (OK)
> %3Cfunction%20poster_url%20at%200x7f8317503c80%3E:1 

The 404s that Gerv reported in comment #19 were caused by an error in the AirMo HLS.JS video template on the staging server.  

That has been corrected.  The video window should now come up with the event thumbnail image.

Thanks Gerv!
(Reporter)

Comment 52

3 years ago
(In reply to Dave Miller [:justdave] (justdave@bugzilla.org) from comment #50)
> It works on Android, yay! \o/
> 
> Tried in Firefox 46 on Mac, Firefox 46 on Linux, and Firefox Mobile 47 on
> Android.
> On all three, the audio sounds like it's clipping.  Everything seems to be
> working otherwise though.

Dave, which version of Android?
Flags: needinfo?(justdave)
(In reply to Richard A Milewski[:richard] from comment #52)
> (In reply to Dave Miller [:justdave] (justdave@bugzilla.org) from comment
> #50)
> > It works on Android, yay! \o/
> > 
> > Tried in Firefox 46 on Mac, Firefox 46 on Linux, and Firefox Mobile 47 on
> > Android.
> > On all three, the audio sounds like it's clipping.  Everything seems to be
> > working otherwise though.
> 
> Dave, which version of Android?

Marshmallow
Flags: needinfo?(justdave)
(Reporter)

Updated

3 years ago
Depends on: 1255606
(Reporter)

Updated

3 years ago
Depends on: 1255610
(Reporter)

Updated

3 years ago
Depends on: 1255611
(Reporter)

Updated

3 years ago
Depends on: 1255613
Mac OS 10.10.5
Firefox 44
Location: Madrid, Spain

I was doing streaming (no audio, I was in another meetings) for an hour or so, and quality was good. No crashes at all. 

Thanks!
David
On my machine, the test stream plays correctly on:

* Firefox 48 on OS X 10.11.3
* Firefox 48 on Windows 10 (VM)
* Edge on Windows 10 (VM)
* IE11 on Windows 10 (VM)

The test stream FAILS to play on:

* Safari 9 on OS X 10.11.3 (flashes a video frame and then reverts to heart logo)
* Chrome 49 on OS X 10.11.3 (stuck on heart logo)
* Chrome 49 on Windows 10 (VM) (stuck on heart logo)

@ Richard, I recommend reporting this problem to the HLS.js devs. The stream works in Firefox and Edge/IE11, so this is likely a bug in HLS.js or a Chrome/Safari quirk that HLS.js should workaround.

https://github.com/dailymotion/hls.js/issues
Flags: needinfo?(richard)
I filed an HLS.js bug report here:

https://github.com/dailymotion/hls.js/issues/316
Flags: needinfo?(richard)
btw, someone on GitHub reports that the audio codec ids in the Air Mo test stream's variant playlist are wrong; the audio tracks are all HE-AAC, so should be mp4a.40.5.

https://github.com/dailymotion/hls.js/issues/316#issuecomment-198586522
Today's project meeting stream [1] still doesn't work in Chrome or Safari. I added some notes to the GitHub issue for HLS.js [2].

[1] https://air.mozilla.org/mozilla-weekly-project-meeting-20160321/
[2] https://github.com/dailymotion/hls.js/issues/316
(Reporter)

Comment 59

3 years ago
(In reply to Chris Peterson [:cpeterson] from comments #56, 57 & 58)


Thanks Chris - I'll try to follow that issue on github.  Are the audio codec id's something that we have control of, or is that buried in the HLS.js library?

...also today updated the HLS.js library on our dev server to the latest release.  No change.

I've started a bug for the problems on Chrome: https://bugzilla.mozilla.org/show_bug.cgi?id=1255611 and I copied your comment #58 over to that bug.

...and opened another for similar behavior on Opera: https://bugzilla.mozilla.org/show_bug.cgi?id=1255613
Flash-free weekly meeting stream would have a few seconds of video and audio playing in sync, then video just completely stops while audio continues playing.

Comment 61

3 years ago
Video froze for me today in latest Firefox 46 Beta on Windows 10
The video for todays project meeting kept freezing for me. After about 30 seconds of watching the video stops updating, the audio continues though. Refreshing the page makes it work again until it freezes again a bit later.
I tried to watch the weekly project meeting on desktop Safari on OS X (10.11.3) without Flash installed. The video plays for less than a second and then stops.

If I dig in the console, I find the m3u8 playlist, which OS X and iOS know how to play natively (it's the same live stream format used for live Apple events):

https://mozillalives-i.akamaihd.net/hls/live/241431/HTTPS_Public/MTV-Commons_720p/chunklist.m3u8

This URL worked in Desktop Safari as well as Safari on iOS.
(Reporter)

Comment 64

3 years ago
(In reply to John Whitlock [:jwhitlock] from comment #63)

John,

My bad!  The description of the Back-up player page used the word "Flash" which is probably why you didn't try it.   ...but it's really just a page that uses JWPlayer instead of the HLS.js pure javascript player.

JWPlayer will play that stream on Safari (OS X and iOS) without using Flash.  It does, however insist on using Flash on Firefox.

I'll fix that description for next week's Project meeting.
(Reporter)

Comment 65

3 years ago
(In reply to John Whitlock [:jwhitlock] from comment #63)

John,

My bad!  The description of the Back-up player page used the word "Flash" which is probably why you didn't try it.   ...but it's really just a page that uses JWPlayer instead of the HLS.js pure javascript player.

JWPlayer will play that stream on Safari (OS X and iOS) without using Flash.  It does, however insist on using Flash on Firefox.

I'll fix that description for next week's Project meeting.
(Reporter)

Comment 66

3 years ago
(In reply to Dave Townsend [:mossop] from comment #62)

(In reply to Wes Kocher (:KWierso) from comment #60)

I was able to reproduce the frozen video, continuing audio problem on both Firefox Dev Edition and the production version of Firefox.  We'll update the HLS.js player and see if that helps.
(Reporter)

Comment 67

3 years ago
(In reply to Luna Jernberg from comment #61)
> Video froze for me today in latest Firefox 46 Beta on Windows 10

Did the audio continue after the video froze?
Flags: needinfo?(bittin)

Comment 68

3 years ago
(In reply to Richard A Milewski[:richard] from comment #67)
> (In reply to Luna Jernberg from comment #61)
> > Video froze for me today in latest Firefox 46 Beta on Windows 10
> 
> Did the audio continue after the video froze?

yep audio still worked

Updated

3 years ago
Flags: needinfo?(bittin)

Comment 69

3 years ago
This function looks wierd: http://i.imgur.com/zzKScRe.jpg

Comment 70

3 years ago
(In reply to Luna Jernberg from comment #69)
> This function looks wierd: http://i.imgur.com/zzKScRe.jpg

Fixed now by reloading the page :)

Comment 71

3 years ago
The player today worked much better then last week :)
Richard, do Chrome and Safari still have problems with HLS.js on Air Mozilla? Is HLS.js officially launched for live streams on Air Mozilla?

I reported the Chrome problem to the HLS.js developers in March, but the bug is still open:

https://github.com/dailymotion/hls.js/issues/316
Flags: needinfo?(richard)
(Reporter)

Comment 73

2 years ago
Apologies for taking so long to see the needinfo on this.  I haven't been spending as much time in bugzilla as I should be for the last couple of months.

We're currently using the CLAPPR wrapper around HLS.js.  The current version is 0.2.61.  We've been using the latest version at https://cdn.jsdelivr.net/clappr/latest/clappr.min.js.  We've had reasonably good luck staying on the bleeding edge and only had to roll back to the previous release once.

Chrome 51.0.2704.103 (64-bit) and 52.0.2743.116 (64-bit) seem to work fine on OS X.

Safari 9.1.2 (11601.7.7) DOES NOT  Which is strange because if you open WEB DEVELOPER > NETWORK from the Firefox TOOLS menu and copy the url of playlist.m3u8 and paste that into the Safari address bar, it plays just fine.   (You need to do that quickly after a page refresh because that url contains a token that is only valid for 90 seconds).

There is now a restricted access stream with a pseudo-live stream running 24/7 at https://air.mozilla.org/browser-test-stream/.  It's restricted only because watching a restricted stream presents the most rigorous browser config problem on AirMo.  Some users at Mozilla with severely locked-down browsers were having trouble watching MoCo meetings and other restricted content.  This gives them a test page 24/7 so we're not trying to problem-solve in irc during a meeting.

It's restricted to staff plus vouched mozillians, so if there are HLS.js developers who need access for testing, they need only join mozillians.org and get vouched. There used to be a 3-vouch requirement, not sure if that's still true.  Let me know if I can help by vouching any developers.
Flags: needinfo?(richard)
Thanks. I added a new note to the HLS.js GitHub bug:

https://github.com/dailymotion/hls.js/issues/316#issuecomment-237723061

If Chrome now works correctly and only Safari fails to play, then this will probably be a low priority for the HLS.js developers. Safari supports HLS natively (as you saw when pasting the playlist.m3u8 URL into Safari's address bar), so I'm not sure what Clappr or HLS.js are actually do on Safari.
(Reporter)

Comment 75

2 years ago
HLS.js is in production now and appears stable.  Closing this, at least for no.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.