url() content not generated when it's not an image

RESOLVED WONTFIX

Status

()

Core
CSS Parsing and Computation
--
major
RESOLVED WONTFIX
16 years ago
14 years ago

People

(Reporter: Nowhere man, Assigned: dbaron)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When the content property of a pseudo-element before or after is set to
url("foo"), this content seems not to be included.
http://www.bath.ac.uk/%7Epy8ieh/internet/eviltests/content/3.html is a testcase
testing this and it's working for me...

Where do you see this fail?
Assignee: asa → dbaron
Component: Browser-General → Style System
QA Contact: doronr → ian
Marking WORKSFORME based on bz's comment.  If you have clear steps to explain to
us how to see the problem that you're seeing, please REOPEN the bug.  Also see
http://mozilla.org/quality/bug-writing-guidelines.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Comments from reporter:

http://dev.moine-fou.org/css/

The span and div tags have an :after including a text file and an
image. And nothing... I verified this very simple code many times, but
there is nothing to do.

---------------------------------

The image URL links to a 404, so that's not a very good test.  :)  The text
document does not appear.  Reopening based on that.
Status: RESOLVED → UNCONFIRMED
OS: Windows 98 → All
Hardware: PC → All
Resolution: WORKSFORME → ---
Summary: url() content seems not to be generated → url() content not generated when it's not an image
Hmmm.  This really isn't the intent of generated content -- after all, it's for
style.  While one *could* say that the spec allows this I think the intent of
the spec was to allow for generated content that is *stylistic*.  After all,
separation of style and content means that your content should be in your
content, not in your style, and your style should be optional.

So I'm going to mark this as WONTFIX because I think the *intent* of the spec
was that this be used for images.

Ian -- is that reasonable?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WONTFIX

Comment 5

14 years ago
*** Bug 252239 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
Artwork like corporate identity stuff ist not content but stylish. I.e. the same
content published on different media types sometimes needs different structured
artwork or differently positioned artwork.

The CSS specification does not limit content:url to images only. If you support
any kind of resource including HTML, XHTML or what ever Mozilla is able to deal
with to be added as content by the stylesheet, you enhance Mozilla and the
composer with one single step to the power of MS-Word templates. No. Not just up
to the power of the MS-Word templates but you leave MS-Word miles behind you,
because they can not change the template after starting to write the document
based on the template. But we can change the stylesheet at any time, which will
then change the look an feel of the document.

I.e. you can change a private letter writte in HTML / XHTML into a business
letter by simply exchanging the stylsheet. Or you can use the same document like
a product sheet with as website stylesheet and a printig stylesheet with totally
different layout.

Fixing this bug might be big step in replacing MS-Office by Mozilla-Office.
You need to log in before you can comment on or make changes to this bug.