Wrong guess of bug which could have introduced the regression

RESOLVED DUPLICATE of bug 1256379

Status

RESOLVED DUPLICATE of bug 1256379
3 years ago
5 months ago

People

(Reporter: epinal99-bugzilla2, Unassigned)

Tracking

45 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Run:
mozregression --bits=32 --good=cbe9a2aea9541146ae0a11051ed32d31e
af4e428 --bad=5ddf0a252b086c7e8e468243c6251af5c0b1da57

Result:
 0:10.23 INFO: Last good revision: cbe9a2aea9541146ae0a11051ed32d31eaf4e428
 0:10.23 INFO: First bad revision: 5ddf0a252b086c7e8e468243c6251af5c0b1da57
 0:10.23 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=cbe9a2
aea9541146ae0a11051ed32d31eaf4e428&tochange=5ddf0a252b086c7e8e468243c6251af5c0b1
da57

 0:10.71 INFO: Looks like the following bug has the changes which introduced the
 regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1175556

But bug 1175556 was a wrong guess, in my case, Bug 1155828 was the faulty.

Comment 1

5 months ago
Created attachment 8973493 [details]
mozregression-gui.txt

1. Is the attached log from mozregression-gui 0.9.22 the same as this bug? The log incorrectly pointed to a., which is a backout. The info box in the top right corner b. points to a fairly wide range and therefore isn't that useful. If I manually piece together a pushlog link c., then I get a narrower range.

a. https://hg.mozilla.org/integration/autoland/json-pushes?changeset=d112cf7b2b60e6244099dc3b599a2444ba0d1da3&full=1
b. https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=763909764666b7d617875226e21cce0c8074b959&tochange=479b6858ea6cf96b4842cf5ae78f3bf9e74d3278
c. https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=6415ccbf739f36f71548540bd92c3b86ab9e1529&tochange=d112cf7b2b60e6244099dc3b599a2444ba0d1da3


2. Is bug 1256379 a duplicate of this? All 3 of these situations involve backouts at least.
Flags: needinfo?(wlachance)
Yeah, we disabled the automatic bug reporting a while back for exactly this reason.

https://github.com/mozilla/mozregression/blob/44f216c091072b7d6c1c2136041e7c04b0e1c89c/mozregression/main.py#L181

I haven't investigated deeply why this doesn't work and don't feel like it's worth the effort (at least for me) at the moment. I suspect it's the sort of thing where there are so many edge cases that it's extremely difficult to get correct, and I'd rather not even try than risk misleading people (which causes no end of confusion).
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Flags: needinfo?(wlachance)
Resolution: --- → DUPLICATE
Duplicate of bug: 1256379
You need to log in before you can comment on or make changes to this bug.