Android OMX plugin used on Jelly Bean and up

RESOLVED FIXED in Firefox 46

Status

()

Firefox for Android
Audio/Video
--
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: snorp, Assigned: esawin)

Tracking

({crash})

45 Branch
Firefox 48
crash
Points:
---

Firefox Tracking Flags

(firefox46 fixed, firefox47 fixed, firefox48 fixed, fennec46+)

Details

(crash signature)

Attachments

(1 attachment)

This bug was filed from the Socorro interface and is 
report bp-00e04d67-e109-49c4-9b9e-419c12160308.
=============================================================

We somehow end up using the old busted media support even on a newer device (API 22). We need to never ever do that. Logcat below:

https://crash-stats.mozilla.com/report/index/00e04d67-e109-49c4-9b9e-419c12160308

03-08 19:24:56.461  8155  8155 D GeckoBrowserApp: BrowserApp.onTabChanged: 1: LOADED
03-08 19:24:56.875  8155  8175 I GeckoBrowserApp: Found tag 
03-08 19:24:56.961  8155  8155 I MediaRouter: Found default route: MediaRouter.RouteInfo{ uniqueId=android/.support.v7.media.SystemMediaRouteProvider:DEFAULT_ROUTE, name=Tablet, description=null, enabled=true, connecting=false, canDisconnect=false, playbackType=0, playbackStream=3, volumeHandling=1, volume=11, volumeMax=15, presentationDisplayId=-1, extras=null, settingsIntent=null, providerPackageName=android }
03-08 19:24:57.693  8155  8175 I AndroidMediaPluginHost: Android Version is: 22
03-08 19:24:57.693  8155  8175 I AndroidMediaPluginHost: Android Release Version is: 5.1.1
03-08 19:24:57.693  8155  8175 I AndroidMediaPluginHost: Android Device is: LIFETAB_S1036X
03-08 19:24:57.693  8155  8175 I AndroidMediaPluginHost: Android Manufacturer is: LENOVO
03-08 19:24:57.693  8155  8175 I AndroidMediaPluginHost: Android Hardware is: anzhen4_mrd8_w
03-08 19:24:57.693  8155  8175 I AndroidMediaPluginHost: Loading OMX Plugin: libomxpluginkk.so
03-08 19:24:57.695  8155  8175 W GeckoLinker: /data/app/org.mozilla.firefox-1/base.apk!/assets/x86/libomxpluginkk.so: unhandled flags #8 not handled
03-08 19:25:00.955  8155  8264 W AudioCapabilities: Unsupported mime audio/alac
03-08 19:25:00.967  8155  8264 W AudioCapabilities: Unsupported mime audio/x-ms-wma
03-08 19:25:00.971  8155  8264 W VideoCapabilities: Unsupported profile 4 for video/avc
03-08 19:25:00.976  8155  8264 W VideoCapabilities: Unsupported mime video/x-ms-wmv
03-08 19:25:00.983  8155  8264 W VideoCapabilities: Unsupported mime video/x-ms-wmv
03-08 19:25:00.988  8155  8264 W VideoCapabilities: Unsupported profile 4 for video/avc
03-08 19:25:01.023  8155  8264 I VideoCapabilities: Unsupported profile 4 for video/mp4v-es
03-08 19:25:01.031  8155  8266 I OMXClient: Using client-side OMX mux.
03-08 19:25:01.045  8155  8266 I MultiDisplay: Video source Info 718x404@0fps
03-08 19:25:01.074  8155  8266 F ACodec  : frameworks/av/media/libstagefright/ACodec.cpp:3763 CHECK_LE( rect.nLeft + rect.nWidth - 1,videoDef->nFrameWidth) failed: 719 vs. 718
03-08 19:25:01.384  8273  8273 D AndroidRuntime: >>>>>> START com.android.internal.os.RuntimeInit uid 10103 <<<<<<
03-08 19:25:01.386  8273  8273 D AndroidRuntime: CheckJNI is OFF
03-08 19:25:01.417  8273  8273 W art     : Could not create mount namespace.
03-08 19:25:01.418  8273  8273 W         : Failed to bind-mount /system/lib/x86/cpuinfo as /proc/cpuinfo: Permission denied
03-08 19:25:01.418  8273  8273 W         : Cannot create code cache directory ./code_cache: Read-only file system.
03-08 19:25:01.449  8273  8273 E HAL     : load: module=/system/lib/hw/memtrack.default.so
03-08 19:25:01.449  8273  8273 E HAL     : dlopen failed: library "/system/lib/hw/memtrack.default.so" not found
03-08 19:25:01.449  8273  8273 E memtrack: Couldn't load memtrack module (Invalid argument)
03-08 19:25:01.449  8273  8273 E android.os.Debug: failed to load memtrack module: -22
03-08 19:25:01.452  8273  8273 D Camera-lfb-JNI: int register_android_hardware_Camera_lfb(JNIEnv*): enter
03-08 19:25:01.452  8273  8273 D Camera-lfb-JNI: int register_android_hardware_Camera_lfb(JNIEnv*): context:0x748385b8
03-08 19:25:01.486  8273  8273 D AndroidRuntime: Calling main entry com.android.commands.am.Am
03-08 19:25:01.512  8155  8172 D GeckoBrowserProvider: Expiring history.
03-08 19:25:01.513  8155  8172 D GeckoBrowserProvider: Expiring thumbnails.
03-08 19:25:01.522  8273  8273 D AndroidRuntime: Shutting down VM
03-08 19:25:01.587  8117  8117 I GeckoCrashReporter: moving /data/data/org.mozilla.firefox/files/mozilla/3ucqcldr.default/minidumps/6c007eb5-df3a-f075-462de63f-55cbad1e.dmp to /data/data/org.mozilla.firefox/files/mozilla/Crash Reports/pending/6c007eb5-df3a-f075-462de63f-55cbad1e.dmp
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #0)
> This bug was filed from the Socorro interface and is 
> report bp-00e04d67-e109-49c4-9b9e-419c12160308.
> =============================================================
> 
> We somehow end up using the old busted media support even on a newer device
> (API 22). We need to never ever do that. Logcat below:
> 
> https://crash-stats.mozilla.com/report/index/00e04d67-e109-49c4-9b9e-
> 419c12160308
> 
> 03-08 19:24:56.461  8155  8155 D GeckoBrowserApp: BrowserApp.onTabChanged:
> 1: LOADED
> 03-08 19:24:56.875  8155  8175 I GeckoBrowserApp: Found tag 
> 03-08 19:24:56.961  8155  8155 I MediaRouter: Found default route:
> MediaRouter.RouteInfo{
> uniqueId=android/.support.v7.media.SystemMediaRouteProvider:DEFAULT_ROUTE,
> name=Tablet, description=null, enabled=true, connecting=false,
> canDisconnect=false, playbackType=0, playbackStream=3, volumeHandling=1,
> volume=11, volumeMax=15, presentationDisplayId=-1, extras=null,
> settingsIntent=null, providerPackageName=android }
> 03-08 19:24:57.693  8155  8175 I AndroidMediaPluginHost: Android Version is:
> 22
> 03-08 19:24:57.693  8155  8175 I AndroidMediaPluginHost: Android Release
> Version is: 5.1.1
> 03-08 19:24:57.693  8155  8175 I AndroidMediaPluginHost: Android Device is:
> LIFETAB_S1036X
> 03-08 19:24:57.693  8155  8175 I AndroidMediaPluginHost: Android
> Manufacturer is: LENOVO
> 03-08 19:24:57.693  8155  8175 I AndroidMediaPluginHost: Android Hardware
> is: anzhen4_mrd8_w
> 03-08 19:24:57.693  8155  8175 I AndroidMediaPluginHost: Loading OMX Plugin:
> libomxpluginkk.so
> 03-08 19:24:57.695  8155  8175 W GeckoLinker:
> /data/app/org.mozilla.firefox-1/base.apk!/assets/x86/libomxpluginkk.so:
> unhandled flags #8 not handled
> 03-08 19:25:00.955  8155  8264 W AudioCapabilities: Unsupported mime
> audio/alac
> 03-08 19:25:00.967  8155  8264 W AudioCapabilities: Unsupported mime
> audio/x-ms-wma
> 03-08 19:25:00.971  8155  8264 W VideoCapabilities: Unsupported profile 4
> for video/avc
> 03-08 19:25:00.976  8155  8264 W VideoCapabilities: Unsupported mime
> video/x-ms-wmv
> 03-08 19:25:00.983  8155  8264 W VideoCapabilities: Unsupported mime
> video/x-ms-wmv
> 03-08 19:25:00.988  8155  8264 W VideoCapabilities: Unsupported profile 4
> for video/avc
> 03-08 19:25:01.023  8155  8264 I VideoCapabilities: Unsupported profile 4
> for video/mp4v-es
> 03-08 19:25:01.031  8155  8266 I OMXClient: Using client-side OMX mux.
> 03-08 19:25:01.045  8155  8266 I MultiDisplay: Video source Info 718x404@0fps
> 03-08 19:25:01.074  8155  8266 F ACodec  :
> frameworks/av/media/libstagefright/ACodec.cpp:3763 CHECK_LE( rect.nLeft +
> rect.nWidth - 1,videoDef->nFrameWidth) failed: 719 vs. 718
It looks like this crash is caused by this assertion.
(Assignee)

Comment 2

2 years ago
Created attachment 8729065 [details] [diff] [review]
0001-Bug-1255050-1.1-Restrict-media-plugin-decoder-usage-.patch
Attachment #8729065 - Flags: review?(snorp)
Attachment #8729065 - Flags: review?(snorp) → review+
tracking-fennec: --- → ?
Eugen, go ahead and plan to uplift this
(Assignee)

Updated

2 years ago
Summary: crash in EMPTY: no crashing thread identified; ERROR_NO_MINIDUMP_HEADER → Android OMX plugin used on Jelly Bean and up
(In reply to Blake Wu [:bwu][:blakewu] from comment #1)
> > 03-08 19:25:01.031  8155  8266 I OMXClient: Using client-side OMX mux.
> > 03-08 19:25:01.045  8155  8266 I MultiDisplay: Video source Info 718x404@0fps
> > 03-08 19:25:01.074  8155  8266 F ACodec  :
> > frameworks/av/media/libstagefright/ACodec.cpp:3763 CHECK_LE( rect.nLeft +
> > rect.nWidth - 1,videoDef->nFrameWidth) failed: 719 vs. 718
> It looks like this crash is caused by this assertion.
 Just guessing: the assertion was on thread 8266, same as the 'MultiDisplay' log. Could it be crashed in the codec used by that rather than Gecko?

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/91e3b9ef848c
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox48: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
tracking-fennec: ? → 46+
Eugen, please uplift.
Flags: needinfo?(esawin)
(Assignee)

Comment 8

2 years ago
Comment on attachment 8729065 [details] [diff] [review]
0001-Bug-1255050-1.1-Restrict-media-plugin-decoder-usage-.patch

Approval Request Comment
[Feature/regressing bug #]: media playback
[User impact if declined]: crash on media playback on some (modern) devices
[Describe test coverage new/current, TreeHerder]: has been on Nightly for some days
[Risks and why]: low, MediaCodec offers more stable support on modern devices
[String/UUID change made/needed]: none
Flags: needinfo?(esawin)
Attachment #8729065 - Flags: approval-mozilla-beta?
Attachment #8729065 - Flags: approval-mozilla-aurora?

Updated

2 years ago
status-firefox47: --- → affected

Comment 9

2 years ago
Hi Margaret, Snorp: This bug is associated with a top crasher on Fennec 48 stability atm. The fix was checked into Nightly on 3/11 and since 3/14 this crash signature has moved up 12 spots to go from #15 to #3 on Nightly. I just wanted a second opinion on whether that uptick on this crash signature is unrelated to this fix. Should we still uplift to Aurora and Beta? Thanks!
Flags: needinfo?(snorp)
Flags: needinfo?(margaret.leibovic)

Comment 10

2 years ago
snorp is better qualified to answer this than me.
Flags: needinfo?(margaret.leibovic)
(In reply to Ritu Kothari (:ritu) from comment #9)
> Hi Margaret, Snorp: This bug is associated with a top crasher on Fennec 48
> stability atm. The fix was checked into Nightly on 3/11 and since 3/14 this
> crash signature has moved up 12 spots to go from #15 to #3 on Nightly. I
> just wanted a second opinion on whether that uptick on this crash signature
> is unrelated to this fix. Should we still uplift to Aurora and Beta? Thanks!

The signature is unrelated, since it's a busted report. I just happened to fish this logcat out from one of those.
Flags: needinfo?(snorp)
Comment on attachment 8729065 [details] [diff] [review]
0001-Bug-1255050-1.1-Restrict-media-plugin-decoder-usage-.patch

Snorp believes this should help, crash fix. Aurora47+, Beta46+
Attachment #8729065 - Flags: approval-mozilla-beta?
Attachment #8729065 - Flags: approval-mozilla-beta+
Attachment #8729065 - Flags: approval-mozilla-aurora?
Attachment #8729065 - Flags: approval-mozilla-aurora+

Updated

2 years ago
status-firefox46: --- → affected

Comment 13

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/7908ee2063b1
status-firefox47: affected → fixed

Comment 14

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/0fc97d88d4b1
status-firefox46: affected → fixed
You need to log in before you can comment on or make changes to this bug.