Performance: Avoidance of Javascript Console Messages

VERIFIED DUPLICATE of bug 112908

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 112908
17 years ago
14 years ago

People

(Reporter: Peter Wilson, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I notice that when Mozilla first loads the following console message appears 
three times:

Error: redeclaration of const hide
Source File: 
chrome://wallet/content/walletOverlay.js
Line: 1
Build 2002021210
This is not a programming problem - but it is a performance hit.
In testing programs I sometimes use a debug statement to write to the JS 
Console. When I do this the program slows by a considerable margin.
1. The JS Console code needs to be loaded.
2. The writes to the console are very slow.

Four attempts, above,  are being made to load the same file (three failed), once 
is sufficient - a clear win. 

I belive you can reduce initial load time by one aboout one second.

Comment 1

17 years ago
dup of bug 112908

Comment 2

17 years ago
The correct thing to do is to fix the assertions

*** This bug has been marked as a duplicate of 112908 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.