Closed Bug 1255121 Opened 6 years ago Closed 6 years ago

Fix test_bug260264.html to run in e10s mode

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla49
Tracking Status
e10s + ---
firefox49 --- fixed

People

(Reporter: ehsan.akhgari, Assigned: ehsan.akhgari)

References

(Blocks 1 open bug)

Details

(Whiteboard: btpp-active)

Attachments

(1 file)

This test currently fails on e10s mode since it relies on gOpenPopupSpamCount being synchronously updated when close() is called on a window, which is not the case in e10s.

Making the close function in the test return a promise that gets resolved when gOpenPopupSpamCount has been updated fixes the test in e10s mode.
Attachment #8728549 - Flags: review?(mrbkap)
Attachment #8728549 - Flags: review?(mrbkap) → review+
Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/4bad8d204efe - not sure what the final percentage will be, since my linux64 retriggers are running horribly slowly, but linux64 opt/pgo and 10.10 opt agree that they are quite likely to hang and time out after 330 seconds without output, https://treeherder.mozilla.org/logviewer.html#?job_id=23419010&repo=mozilla-inbound and https://treeherder.mozilla.org/logviewer.html#?job_id=23415938&repo=mozilla-inbound
I'll see if I can reproduce.
Flags: needinfo?(ehsan)
Depends on: 1255823
Over to kats to investigate bug 1255823.
Flags: needinfo?(ehsan)
Whiteboard: btpp-active
https://hg.mozilla.org/mozilla-central/rev/0e860f5f6bb5
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.