HTTP does not report zero byte pages w/ error

RESOLVED WONTFIX

Status

()

Core
Networking: HTTP
RESOLVED WONTFIX
16 years ago
2 years ago

People

(Reporter: rainer canavan, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.79C-SGI [en] (X11; U; Linux 2.2.20 i686; Nav)
BuildID:     2002020415

If a web server returns no data, mozilla quietly displays an empty page.
View/Source shows page with "<html><body></body></html>". The latter should not
happen, and an error should be flagged in the first place.

Reproducible: Always
Steps to Reproduce:
point mozilla to any url that returns no data

Expected Results:  report error + show empty "view source"
networking.  Should we really error on no data?  That was such an annoying NS4
behavior...
Assignee: asa → new-network-bugs
Component: Browser-General → Networking
QA Contact: doronr → benc
(Reporter)

Comment 2

16 years ago
If a dialog is too annoying, how about a nice error page? I find it much more
annoying not to be told that there has been an error - since most of the time
the delivery of empty pages _is_ in fact a server problem.

Comment 3

16 years ago
I've said we need a message that says "this file is empty", and perhaps a
tex/emtpy-file mime type to go with it.

Comment 4

16 years ago
CONFIRMED:
We have no URL, but I'm certain this happens here.
Assignee: new-network-bugs → darin
Status: UNCONFIRMED → NEW
Component: Networking → Networking: HTTP
Ever confirmed: true
QA Contact: benc → tever

Comment 5

16 years ago
mass futuring of untargeted bugs
Target Milestone: --- → Future

Comment 6

12 years ago
-> default owner
Assignee: darin → nobody
QA Contact: tever → networking.http
Target Milestone: Future → ---

Comment 7

9 years ago
cleanup summary.
Summary: mozilla does not report zero sized answers as an error → HTTP does not report zero byte pages w/ error

Updated

7 years ago
Duplicate of this bug: 583919
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.