Elements in position fixed are truncated when page is zoom out

RESOLVED WORKSFORME

Status

()

Firefox for Android
Toolbar
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: David Romanet, Unassigned)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
Created attachment 8728835 [details]
testcase.html

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.116 Safari/537.36

Steps to reproduce:

- Open the joined testcase (testcase.html)
- zoom out (to see the entire width page)


Actual results:

The element in position fixed (div.overlay) is truncated. Only the initial visible area of the element is rendered (the element div.to-right which is on the right of the fixed element isn't visible).


Expected results:

The element in position fixed (div.overlay) is completly visible.
(Reporter)

Comment 1

2 years ago
Created attachment 8728839 [details]
screenshot of actual result
(Reporter)

Comment 2

2 years ago
Created attachment 8728840 [details]
screenshot of expected result
(Reporter)

Comment 3

2 years ago
Created attachment 8728841 [details]
screenshot with initial zoom (before zoom out)
Hi David,

Thanks for the report! I can reproduce the issue using your attached test case in Firefox 44.0.2 on Android. However it looks like it has been fixed already in Firefox 45, as I was not able to reproduce the problem there. You can get Firefox 45 as "Firefox Beta" on the Play Store to verify. And soon (sometime this week or early next week) Firefox 45 will be out of beta and will be the general release. So the bug should be fixed in the Firefox release channel very shortly.

I'm going to close this bug as fixed, but if you have questions or if you disagree feel free to reopen this bug or post a comment. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.