Remove Tab Groups migration backup in Firefox 48

RESOLVED DUPLICATE of bug 1312406

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1312406
2 years ago
a year ago

People

(Reporter: quicksaver, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I just noticed Firefox creates a backup of the current session into profileDir/sessionstore-backups every time it upgrades. And it only keeps 3 backups by default, so they eventually rotate out.

I wonder if that kinda makes creating a specific (identical?) backup here superfluous, not to mention this one isn't sanitized until the user deletes it manually (which I'm guessing the vast-vast majority of the users don't know how to or won't bother to do it) or until someone writes its removal code (which could be never if no one ever remembers to do it).

BTW, not trying to make any point, it's just a curiosity I noticed.
Gijs, created a new bug like you asked, but as I said it was mostly something I noticed. I'm not sure if there's much that can be done or said about it...

Comment 2

2 years ago
We could potentially remove the backup after a while. If sessionstore-backups rotates after 3 versions then presumably 3 versions == "a while", so doing this in version 48 (current Nightly!) would make sense. That or wontfix. But at least now we can make a documented decision without spamming everyone on the CC list of the other bug. :-)

Dolske, thoughts?
Flags: needinfo?(dolske)
Fine with me. IIRC this was more of a paranoia backup, lest we find the migration to bookmarks was broken/inadequate. Unless we suddenly see a flood of such reports now that 45 is released, there's not much value in keeping this around.
Flags: needinfo?(dolske)

Updated

2 years ago
Summary: Tab Groups migration backup may be redundant? → Remove Tab Groups migration backup in Firefox 48
Component: Panorama → General
This is being done in part 2 of bug 1312406.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1312406
You need to log in before you can comment on or make changes to this bug.