NSS 3.23 no longer builds using NSS_NO_PKCS11_BYPASS=1

RESOLVED FIXED in 3.24

Status

NSS
Libraries
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: kaie, Assigned: kaie)

Tracking

trunk
3.24

Firefox Tracking Flags

(firefox48 affected)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
NSS 3.23 no longer builds using NSS_NO_PKCS11_BYPASS=1

This is caused by "warnings are errors" and ssl3_CanBypassCipher.

When setting the variable, the function is never used, and the compiler aborts.
(Assignee)

Comment 1

2 years ago
Created attachment 8729022 [details] [diff] [review]
1255443-v1.patch
Assignee: nobody → kaie
Attachment #8729022 - Flags: review?(ttaubert)
Comment on attachment 8729022 [details] [diff] [review]
1255443-v1.patch

Review of attachment 8729022 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8729022 - Flags: review+
Attachment #8729022 - Flags: review?(ttaubert) → review+
(Assignee)

Comment 3

2 years ago
https://hg.mozilla.org/projects/nss/rev/b1fbfdccc247
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.24
You need to log in before you can comment on or make changes to this bug.