Mozilla hangs when selecting drop-down items

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
--
critical
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Ilia, Assigned: mkaply)

Tracking

({hang})

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Mozilla hangs when selecting a number (2..4) drop-down selection items in the
blue box on the page. Even another Mozilla windows with the totally unrelated
URLs are stuck.
It's possible to kill the browser by right-clicking on one of the Mozilla tabs
on the task bar and than selecting "Close" but that's all.

Steps to reproduce:
1.Load the URL
2.In the blue box on the page select the drop-down selection items in sequence.
The sequence of selection seems to not matter, but it need to select from the
2-4 different drop-down selection boxes to reproduce the bug.

(Note: This is the used cars trade site, so the items are represent car   year,
engine volume(in cc), etc.)


Additional info:
1. The page is in Hebrew. It may look as gibberish if no Hebrew fonts are
installed on the computer.
2. The trouble-making selection code is in the table with attribute:
bgcolor="#3366cc". Search for this string to get to it

Comment 1

16 years ago
Workforme    Build:2002021203   OS:WinNT

Comment 2

16 years ago
WFM, Build ID: 2002021308, SuSE Linux 7.2

Comment 3

16 years ago
Hung for me: Windows XP build 2002021303.
The second scroll box was what did it after clicking an item (2400, I think).  I
changed apps and the scroll box still appears.  I swapped back to Mozilla and it
didn't work.  I was running it in a tabbed browser.

Comment 4

16 years ago
Workforme    Build: 2002022503   OS:Win98se

Comment 5

16 years ago
Reporter, do you still hang with latest nightly build ?
Build available here:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-talkback.zip
Keywords: hang
(Reporter)

Comment 6

16 years ago
YES! It hangs even the latest buld 2002030908 
It take me to select 1400 from the second drop-down box in the blue area
(marked נפח מנוע) only
in order to hang it.
Interestingly enough, it also hang when I cut-and-paste 
the drop-down box label (in Hebrew, see above) 
from the mentioned page into this report
and than press <Enter> _left_ of it in order to put it on the new line.
Maybe, this is the BiDi issue, and not the forms ?? 

Comment 7

16 years ago
I don't hang using build 2002030908 on Win2k and selection 1400 from the second
dropdown box in blue area. Can you do one more thing ? Try to create a new
profile 'mozilla -profilemanager' and check if you still hang.
Do you have a special Windows NT4 'hebrew' version, special fonts ? Do you crash
on other hebrew sites ?
Component: HTML Form Controls → BiDi Hebrew & Arabic
(Reporter)

Comment 8

16 years ago
It hang for me even when working from a new, "clean" profile.
(The only change I'd had to do is to set the proxy - now there is no connection
from here w/o proxy).

FWIW it was hang even when with direct access (no proxy).

All this, of course with the nighty build 2002030908 

The system information (as written in the DrWatson log):
        Computer Name: ILIA_BOSIS
        User Name: IBosis
        Number of Processors: 1
        Processor Type: x86 Family 6 Model 8 Stepping 6
        Windows Version: 4.0
        Current Build: 1381
        Service Pack: 6
        Current Type: Uniprocessor Free

System Properties show:

Microsoft Windows NT
        4.00.1381
        IE5 5.00.2314.1003

Comment 9

16 years ago
Ilia, when crashing, do you get a Talkback report window popup ? Is so, can you
fill it, send the crash report and then post the associated Talkback ID here ?
You can see your Talkback ID by running 'mozilla\components\talkback.exe' after
having crashed.
Keywords: stackwanted
(Reporter)

Comment 10

16 years ago
Some more clarifications:
It *not* crashes, it hangs !
The symptoms are:
-- The Mozilla not responding - all the windows, not only the one with the URL;
-- The Task Manager shows about 99% CPU utilization by the Mozilla.exe;
-- Another NT applications are still alive;
-- Mozilla may be closed from the Task Manager or from the taskbar;
-- In the closure process there is a message box saying 
   that "the application does not responding" 
   and giving the option of closing it anyway.
-- No crash log is generated, as there is *no* crash !

In short, it looks as the Moz is spinning in an endless loop.
  
Another piece of info: it's hang when a number of pages opened in the single
Mozilla window (using the tabs).
With only one page per window (no tabs) it's not happens for me.

Comment 11

16 years ago
Ilia, sorry, I initially understood it hang, then crashed because you mentioned
Dr. Watson.
Do you still hang when desactivating JavaScript for the Navigator (Preferences
-> Advanced -> Scripts and Windows) ?

Sorry if this is long but if we can better focus which Mozilla component is
involved, you're likely to get faster replies from the appropriate Mozilla
developer.
Keywords: stackwanted
(Reporter)

Comment 12

16 years ago
Some more clarifications:
It's NOT crashes !
The Dr Watson log, I'd mentioned is from some another, unrelated crash.
It just a useful source to get the system information ;) .

It's hang with JavaScript disabled, as well.
Again You need the tabbed browser window with some another page in another tab
to hang it.
I routinely use this bug report page as the "another page" to get the tabbed
browser window.

Try the follows:
-- Open this bug report page
-- Select File->New->Tab
-- In the new tab open the URL: http://www.egzoz.co.il/search.asp 
-- Select 1400 from the 2-nd box in the blue area.
It hangs for me in 100% cases ! 

Comment 13

16 years ago
I still cannot get it to hang, marking NEW to get wider audience and as reporter
hangs Mozilla 100%.
(sorry if this is not the right component, you might move to Tabbed Browser)
Assignee: rods → mkaply
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: madhur → zach
(Reporter)

Comment 14

16 years ago
Works for me with Moz build 2002051006 on WinNT4 SP6 (NT 4.00.1381)
Cannot be sure if it's because of the bug fix in the Mozilla, or the site fixed
their Java Script.
Anyway, the site is looks exactly as it was months before, so I tend to think
that it's some Mozilla code fix that cured it.
Thanks !

RESOLVED WORKSFORME per comment 14
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.