Closed Bug 1255575 Opened 5 years ago Closed 5 years ago

TypeError: upgrade_mercurial() takes exactly 1 argument (2 given) on Fedora

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(firefox48 fixed)

RESOLVED DUPLICATE of bug 1254908
Tracking Status
firefox48 --- fixed

People

(Reporter: keeler, Assigned: gkw)

References

Details

(Keywords: regression)

Attachments

(1 file)

Running ./mach bootstrap, I encountered this error on Fedora:

TypeError: upgrade_mercurial() takes exactly 1 argument (2 given)

Looking through bugzilla, I found bug 885572, which appears to have fixed this problem before, but I suppose it's regressed now.
This likely regressed from bug 1169089. Patch coming up.
Assignee: nobody → gary
Blocks: 1169089
Status: NEW → ASSIGNED
Keywords: regression
Attachment #8729177 - Flags: review?(gps)
I reviewed this exact patch in bug 1254908 :)
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1254908
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.