Closed Bug 1255614 Opened 4 years ago Closed 4 years ago

make ProcessInvalidationList to insert accessibles instead the recaching

Categories

(Core :: Disability Access APIs, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla48
Tracking Status
firefox48 --- fixed

People

(Reporter: surkov, Assigned: surkov)

Details

Attachments

(1 file)

Attached patch patchSplinter Review
No description provided.
Attachment #8729239 - Flags: review?(yzenevich)
Comment on attachment 8729239 [details] [diff] [review]
patch

Review of attachment 8729239 [details] [diff] [review]:
-----------------------------------------------------------------

looks good
Attachment #8729239 - Flags: review?(yzenevich) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/14092b3cacbeaab373eb88792f90800e21d2f1f3
Bug 1255614 - make ProcessInvalidationList to insert accessibles instead the recaching, r=yzen
https://hg.mozilla.org/mozilla-central/rev/14092b3cacbe
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
Backed out because it depends on bug 1255009 (at least from a code conflict point of view).
https://hg.mozilla.org/integration/mozilla-inbound/rev/9061557bdd26
Assignee: nobody → surkov.alexander
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla48 → ---
This, or bug 1255009, causes a regression when an li within an ul is being changed/updated. This can be observed in IRCCloud:

1. Log into https://irccloud.mozilla.com.
2. Ask someone to send you a private message.

Result: Near the top of the page, a list item is being inserted or updated that points to the person who sent you that message.

Before these two bugs landed (they landed together), the updated item would contain a number (the badge), plus the link to the person. Now, after these two bugs landed, the list item gets updated, but NVDA sees it as empty. Not even a page refresh (NVDA+F5) can make the link and the number return to the list item.

So whatever either of these bugs, or the two of them in concert, do, breaks the tree update when the badge gets inserted.
https://hg.mozilla.org/integration/mozilla-inbound/rev/f0574554378bfa00569f243399bd14414592d9b2
Bug 1255614 - make ProcessInvalidationList to insert accessibles instead the recaching, r=yzen
https://hg.mozilla.org/mozilla-central/rev/f0574554378b
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
You need to log in before you can comment on or make changes to this bug.