"Clear Recent History" dialog pops up out of screen. I.e. it is not visible

VERIFIED FIXED in Firefox 47

Status

()

defect
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: alice0775, Assigned: jfkthame)

Tracking

({regression})

47 Branch
mozilla48
Unspecified
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox46 unaffected, firefox47 verified, firefox48 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
This is since Aurora47.0a2.

Reproducible: always

Steps To Reproduce:
1. Move browser window to the bottom of screen so that only the toolbar(TitleBar/MenuBar/NavBar) is visible.
2. Open "Clear Recent History" (Ctrl+Shift+Del)

Actual Results:
"Clear Recent History" dialog pops up out of screen. 
I.e. it is not visible.

Expected Results:
"Clear Recent History" dialog should pop up within the screen.
(Assignee)

Comment 2

3 years ago
Is this problem still present in the latest Nightly?
Flags: needinfo?(alice0775)
(Reporter)

Comment 3

3 years ago
(In reply to Jonathan Kew (:jfkthame) from comment #2)
> Is this problem still present in the latest Nightly?

Yes, I can still reproduce.

https://hg.mozilla.org/mozilla-central/rev/f0c0480732d36153e8839c7f17394d45f679f87d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0 ID:20160314030215
Flags: needinfo?(alice0775)
(Assignee)

Comment 4

3 years ago
OK, thanks; I'll try to debug. Is this Win7 only (not 8.1 or 10)?
(Reporter)

Comment 5

3 years ago
It happens on win10 too.

Okay, It happens if detail pane was expanded at once. Then the problem will persist across session.


Steps To Reproduce:
1. Open "Clear Recent History" (Ctrl+Shift+Del)
2. Click expand icon to expand details pane
3. Close the dialog

4. Move browser window to the bottom of screen so that only the toolbar(TitleBar/MenuBar/NavBar) is visible.
5. Open "Clear Recent History" (Ctrl+Shift+Del)
(Assignee)

Updated

3 years ago
Assignee: nobody → jfkthame
Status: NEW → ASSIGNED
(Assignee)

Comment 7

3 years ago
This is a lot like bug 1242449; it's the problem of sizing vs positioning. We need to position the window (on the appropriate screen, so that it gets the right resolution) before we can size it properly; but we need it sized properly before we can constrain its position correctly. Bug 1242449 fixed this for windows that are sized based on their XUL-specified dimensions, but we also need to handle the case where the window is intrinsically-sized.

Try run with this patch: https://treeherder.mozilla.org/#/jobs?repo=try&revision=266a8b9f5997
Attachment #8730731 - Flags: review?(VYV03354) → review+
(Assignee)

Comment 8

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/21e9dd187ca87f1eec65888aa373559a2c3e9ab1
Bug 1255645 - Ensure nsXULWindow constrains the window to the bounds of its screen after applying intrinsic sizing (if appropriate), by re-doing positioning after the window has been sized properly. r=emk
(Assignee)

Comment 9

3 years ago
Comment on attachment 8730731 [details] [diff] [review]
Ensure nsXULWindow constrains the window to the bounds of its screen after applying intrinsic sizing (if appropriate), by re-doing positioning after the window has been sized properly

Approval Request Comment
[Feature/regressing bug #]: 890156 (per-monitor dpi)

[User impact if declined]: Dialog windows such as "Clear Recent History" may open largely off-screen, making them difficult to interact with (or even to find, if the user doesn't realize what happened).

[Describe test coverage new/current, TreeHerder]: Tested manually.

[Risks and why]: Low - minimal patch in XUL window setup to ensure the position is constrained properly.

[String/UUID change made/needed]: none


Note that although this is a regression caused by the Windows per-monitor dpi changes, it can affect users without per-monitor dpi support (e.g. Win7) as well, and it will persist even if we disable per-monitor dpi support via the firefox.exe manifest.

As such, we need this fix on Aurora even if we decide to hold back actually shipping per-monitor dpi to users for another cycle.
Attachment #8730731 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 12

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/798395b00a7d03203266b6d3d029846255ff7686
Bug 1255645 - Ensure nsXULWindow constrains the window to the bounds of its screen after applying intrinsic sizing (if appropriate), by re-doing positioning after the window has been sized properly. r=emk
(Assignee)

Comment 13

3 years ago
(In reply to Carsten Book [:Tomcat] from comment #10)
> Hi,
> 
> backed this out in 
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-
> inbound&revision=7c210149e23c since one of the changes caused reftest
> failures like :
> 
> https://treeherder.mozilla.org/logviewer.html#?job_id=23888478&repo=mozilla-
> inbound

That was bug 1255158 (unrelated, but pushed at the same time), so I've re-landed this one.
Flags: needinfo?(jfkthame)
Comment on attachment 8730731 [details] [diff] [review]
Ensure nsXULWindow constrains the window to the bounds of its screen after applying intrinsic sizing (if appropriate), by re-doing positioning after the window has been sized properly

Trying to improve multi-mon drag-drop-resize experience, Aurora47+
Attachment #8730731 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 15

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/798395b00a7d
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
(Assignee)

Comment 16

3 years ago
Note that this won't transplant cleanly to aurora right now; it builds on the patch in bug 1242449 (where an approval request is still pending), so we need that one to be uplifted first.
Depends on: 1242449
Flags: qe-verify+
Reproduced the initial issue using old Nightly from (2016-03-24), verified that the issue is fixed using latest Developer Edition 48.0a2 and Firefox 47 beta 8 on Windows 10, 8.1 and 7.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.