Error handling for plain text files

RESOLVED FIXED

Status

Testing
General
RESOLVED FIXED
a year ago
2 months ago

People

(Reporter: Titus Fortner, Unassigned)

Tracking

(Blocks: 1 bug, {ateam-marionette-server})

45 Branch
ateam-marionette-server
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.116 Safari/537.36

Steps to reproduce:

plain_text is:
      content_type 'text/plain'
      'This is text/plain'

-> POST session/838c7f98-223b-6b46-b953-c5eed1d18912/url
   >>> http://127.0.0.1:4444/session/838c7f98-223b-6b46-b953-c5eed1d18912/url | {"url":"file:///Users/tfortner/git/watir_temp/watir-webdriver/spec/watirspec/html/plain_text"}
     > {"Accept"=>"application/json", "Content-Type"=>"application/json; charset=utf-8", "Content-Length"=>"94"}
1457737278722	Marionette	TRACE	conn0 -> [0,2,"get",{"url":"file:///Users/tfortner/git/watir_temp/watir-webdriver/spec/watirspec/html/plain_text"}]
1457737278820	Marionette	TRACE	conn0 <- [1,2,{"error":"unknown error","message":"Error loading page","stacktrace":null},null]
<- {"error":"unknown error","message":"Error loading page"}



Actual results:

raised unknown error message


Expected results:

All other drivers raise UnknownObjectException when trying to access DOM elements on plain/text-page
It's worth adding that the specification isn't entirely clear on how to handle documents of a different doctype than HTML, and this should also be fixed.
Blocks: 721859
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: ateam-marionette-server
This appears to work in Nightly now, probably due to whimboo’s recent page load algorithm changes.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.