Closed Bug 1255976 Opened 8 years ago Closed 8 years ago

tree-view.css should be in skin, so allow theming

Categories

(DevTools :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: alfredkayser, Unassigned)

References

Details

tree-view.css should be moved to /skin/ to allow theming.
Blocks: 1247065
I'm not sure what the /skin/ folder is, but all the devtools styles live in devtools/client/themes.  I don't think we should move just a single file though.  Moving all of the styles would be another discussion
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
The point is that there referenced as "resource://devtools/..." instead of chrome://devtools/skin/..
This prevents custom themes to provide their own versions of these stylesheets.

For example, in the patch for bug 1201475 there is:
  <link href="resource://devtools/client/dom/content/dom-view.css" rel="stylesheet" />
  <link href="resource://devtools/client/jsonview/css/toolbar.css" rel="stylesheet" />
  <link href="resource://devtools/client/shared/components/tree/tree-view.css" rel="stylesheet" />
  <link href="resource://devtools/client/dom/content/components/search-box.css" rel="stylesheet" />

Perhaps it is by design that custom themes are no longer allowed to theme these components?
This is conflicting with the open goals of Mozilla.
Some bits of "structural" styles have been outside of devtools/client/themes for a while now, but newer tools like shared components, RDM, etc. have been keeping more CSS near the tool including the parts that a theme might be interested in changing.

Perhaps some of these things will be moved to devtools/client/themes (which is under chrome://devtools/skin[1]), perhaps not.  I think we would mainly decide based on what's the most efficient for the DevTools team to work on our styles.

The fact the DevTools styles were easy to theme in the past was mostly an accident.  We have never (AFAIK) actively chosen to support restyling DevTools from custom Firefox themes.  It has been possible historically, but it was not an explicit goal for the team to support this kind of customization.

We have discussed ways of making it easier to customize DevTools appearance, but we haven't committed to a specific approach so far.

[1]: https://dxr.mozilla.org/mozilla-central/search?q=devtools%2Fskin&case=true
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.