Closed Bug 1256025 Opened 4 years ago Closed 4 years ago

C5027 and C5026 move|copy assignment operator was implicitly defined as deleted

Categories

(Core :: MFBT, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1124033

People

(Reporter: gps, Unassigned)

References

Details

We are currently suppressing a bunch of new compiler warnings in VS2015. See also bug 1124033. To reproduce these warnings, remove "-Wv:18" from old-configure.in.

obj-i686-pc-mingw32/dist/include/mozilla/Array.h:58 [C5027] 'mozilla::Array<ValueType,12>': move assignment operator was implicitly defined as deleted
obj-i686-pc-mingw32/dist/include/mozilla/Atomics.h:593 [C5026] 'mozilla::detail::AtomicBase<T,mozilla::SequentiallyConsistent>': move constructor was implicitly defined as deleted
obj-i686-pc-mingw32/dist/include/mozilla/Atomics.h:593 [C5026] 'mozilla::detail::AtomicBase<T,mozilla::ReleaseAcquire>': move constructor was implicitly defined as deleted
obj-i686-pc-mingw32/dist/include/mozilla/Atomics.h:593 [C5027] 'mozilla::detail::AtomicBase<T,mozilla::Relaxed>': move assignment operator was implicitly defined as deleted
obj-i686-pc-mingw32/dist/include/mozilla/Atomics.h:593 [C5026] 'mozilla::detail::AtomicBase<T,mozilla::Relaxed>': move constructor was implicitly defined as deleted
obj-i686-pc-mingw32/dist/include/mozilla/Atomics.h:593 [C5027] 'mozilla::detail::AtomicBase<T,mozilla::SequentiallyConsistent>': move assignment operator was implicitly defined as deleted
obj-i686-pc-mingw32/dist/include/mozilla/Atomics.h:593 [C5027] 'mozilla::detail::AtomicBase<T,mozilla::ReleaseAcquire>': move assignment operator was implicitly defined as deleted
obj-i686-pc-mingw32/dist/include/mozilla/Atomics.h:615 [C5027] 'mozilla::detail::AtomicBaseIncDec<T *,mozilla::ReleaseAcquire>': move assignment operator was implicitly defined as deleted
obj-i686-pc-mingw32/dist/include/mozilla/Atomics.h:615 [C5027] 'mozilla::detail::AtomicBaseIncDec<T,mozilla::SequentiallyConsistent>': move assignment operator was implicitly defined as deleted
obj-i686-pc-mingw32/dist/include/mozilla/Atomics.h:615 [C5026] 'mozilla::detail::AtomicBaseIncDec<T,mozilla::SequentiallyConsistent>': move constructor was implicitly defined as deleted
obj-i686-pc-mingw32/dist/include/mozilla/Atomics.h:615 [C5026] CoreDump.pb.cc
obj-i686-pc-mingw32/dist/include/mozilla/Logging.h:151 [C5027] 'mozilla::LazyLogModule': move assignment operator was implicitly defined as deleted
obj-i686-pc-mingw32/dist/include/mozilla/Pair.h:62 [C5027] 'mozilla::detail::PairHelper<A,B,mozilla::detail::AsMember,mozilla::detail::Asnormalizer2.cpp
obj-i686-pc-mingw32/dist/include/mozilla/Pair.h:62 [C5027] 'mozilla::detail::PairHelper<A,B,mozilla::detail::AsMember,mozilla::detail::AsMember>': move assignment operator was implicitly defined as deleted
Blocks: 1124033
We decided to globally disable C5027 and C5027 instead.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1124033
You need to log in before you can comment on or make changes to this bug.