Closed Bug 12561 Opened 21 years ago Closed 21 years ago

[PP]Subjects with text followed by a number don't sort correctly

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 8792

People

(Reporter: nbaca, Assigned: nhottanscp)

Details

Build 1999082412M9: Linux/Redhat 6.0

Overview: Subjects with text followed by a number (i.e. test1, test2) do not
sort correctly.

Step to Reproduce:
1. Start Mail
2. Create and send messages with the Subject using text followed by a number
(i.e. test1, test2, test3 through test10)
3. Get the messages
4. Create and send 10 more messages with the same subjects test1-test20
5. Get messages
6. Sort by Subject (either by selecting the Subject column or View/Sort/by
Subject.

Actual Results: The test messages do not sort in logical order. For instance, it
displays test1, test9, test8, test7, test6, test4, test3, test2, test4, test3,
test2, test1.
Expected Results: I would expect the subjects to be ordered alphabetically.

Other Platforms/Versions:
- Win32/NT4: Build 8/24 sorts as expected.
- Mac 8.5.1: Build 8/24 sorts as expected.
- Wanted to try today's build for Linux but too many problems with the scroll
bar and viewing messages. I will try later.
Assignee: phil → nhotta
Probably a collation key bug. Reassign to nhotta, cc putterman.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 8792 ***
Status: RESOLVED → VERIFIED
Mark it a verified/dup.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.