If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

RTCPeerConnection doc lists "urls" as an RTCIceServer property but everywhere else uses "url"

RESOLVED FIXED

Status

Developer Documentation
General
P5
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Hans Stienen, Assigned: sheppy)

Tracking

Details

(URL)

(Reporter)

Description

2 years ago
:: Developer Documentation Request

      Request Type: Correction
     Gecko Version: unspecified
 Technical Contact: 

:: Details

In all examples that I have seen so far, always 'url' was used in stead of 'urls'. As you can imagine, as long as my application is not running, all kind of inconsistencies make me crazy.
(Assignee)

Comment 1

2 years ago
(In reply to Hans Stienen from comment #0)
> :: Developer Documentation Request
> 
>       Request Type: Correction
>      Gecko Version: unspecified
>  Technical Contact: 
> 
> :: Details
> 
> In all examples that I have seen so far, always 'url' was used in stead of
> 'urls'. As you can imagine, as long as my application is not running, all
> kind of inconsistencies make me crazy.

Hans,

The WebRTC specification changed a while back. They changed the "url" property to be an array, called "urls". There's a *lot* of out-of-date documentation and sample code for WebRTC out there, and they tend to use "url" (which is for now still supported but not for much longer).

So this article is correct. However, I will add a note about the old "url" property.
Assignee: nobody → eshepherd
Summary: Inconsistency → RTCPeerConnection doc lists "urls" as an RTCIceServer property but everywhere else uses "url"
(Assignee)

Comment 2

2 years ago
Updated https://developer.mozilla.org/en-US/docs/Web/API/RTCConfiguration to include information about the old "url" property. Also added a paragraph reminding developers not to include more servers in the list than necessary, since each gets tested before one is finally selected.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.