Closed Bug 1256188 Opened 5 years ago Closed 5 years ago

Extremely poor webgl performance

Categories

(Core :: Canvas: WebGL, defect)

46 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1010527

People

(Reporter: keziolio123, Unassigned)

Details

(Whiteboard: gfx-noted)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160308181531

Steps to reproduce:

Open a webgl page or game like this http://threejs.org/examples/webgl_geometry_convex.html

The system is arch linux with latest nvidia drivers, informations about firefox:
https://gist.github.com/Keziolio/fc52dc68c831a4444b4b


Actual results:

The framerate is extremely poor, about 40 to 80 fps, when in chromium on the same page, in the same machine, the framerate is around 1100-1300 fps

When running the thing, a cpu core goes to a 100% utilization, suggesting that maybe hardware acceleration is not used, but this is only happening on the last few days (probably after 45.0 release), it used to work fine.

Tried in firefox dev, refreshed.
Component: Untriaged → Canvas: WebGL
Product: Firefox → Core
Tested also on my laptop, with arch linux, firefox stable: 35 fps. chromium stable: 120 fps.
It's probably using intel graphics and drivers, i7 5700HQ
I can't make a direct test because i can't use the dedicated gpu directly, but there's still a big performance difference.
Could you run mozregression to find a regression range about the loss of perf, please.
http://mozilla.github.io/mozregression/
Flags: needinfo?(keziolio123)
I downloaded firefox 44, 43, 45, 46 and the problem was still present, so i'm not really sure if that's useful. It was fine back in 44/43 but now it's not, probably the problem is somewhere else. I don't know.

I tried with different profiles and have done a refresh in the meantime.

As I said chromium and 3d games work fine...
Flags: needinfo?(keziolio123)
I tested this using  http://threejs.org/examples/webgl_geometry_convex.html page and I can't see such major differences in performance: 
 - Firefox 43, Firefox 45, Nightly 48: 45-48 fps
 - Chromium, Chrome: 55 - 60 fps

I have Ubuntu 15.04 with Intel graphics.
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Whiteboard: gfx-noted
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: slow-linux-webgl
You need to log in before you can comment on or make changes to this bug.