Tap-then-drag on scrollbar jumps wildly

RESOLVED DUPLICATE of bug 1280667

Status

()

Core
Panning and Zooming
RESOLVED DUPLICATE of bug 1280667
2 years ago
2 years ago

People

(Reporter: kats, Assigned: kats)

Tracking

({regression})

Trunk
Unspecified
Windows
regression
Points:
---

Firefox Tracking Flags

(firefox47 unaffected, firefox48 unaffected, firefox49 unaffected, firefox50 fixed)

Details

(Whiteboard: [gfx-noted][nightly only])

From https://bugzilla.mozilla.org/show_bug.cgi?id=1231570#c3:

Another issue which may be related is that if I try to drag the scrollbar up and down (using tap-then-drag), the page starts to jump around wildly at various points during the scroll. If I try to touch-drag (i.e. no tap first, which works on release Firefox and other browsers), it treats it like a touch scroll, rather than my trying to drag the scrollbar.
Most of the time I try to reproduce this I run into bug 1256344, so I'll try again on the March 17 nightly which should have that fix.
I can repro on March 17 nightly. You need to tap-drag on the scrollthumb to repro (touch down, touch up, touch down, touch move). The same STR with dom.w3c_touch_events.enabled=0 works fine, but with APZ's handling of touch events the scrollthumb jumps around when panning fast. Very similar to what was happening in bug 1244549, and the 4 patches in bug 1242690 that were supposed to take care of the scrollbar might be related.

Still, this is nightly-only as that's where APZ is handling touch events on windows.
Status: UNCONFIRMED → NEW
status-firefox47: --- → unaffected
status-firefox48: --- → affected
Ever confirmed: true
Keywords: regression
See Also: → bug 1242690
Whiteboard: [gfx-noted]
See Also: → bug 1258851
Assignee: nobody → bugmail.mozilla
Whiteboard: [gfx-noted] → [gfx-noted][nightly only]
status-firefox48: affected → unaffected
status-firefox49: --- → affected
Tracking since we are looking to ship apz.
status-firefox50: --- → affected
tracking-firefox49: --- → +
tracking-firefox50: --- → +
No touch on 49.
status-firefox49: affected → unaffected
tracking-firefox49: + → ---
This is fixed in the latest nightly, presumably by bug 1280667.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox50: affected → fixed
Resolution: --- → DUPLICATE
Duplicate of bug: 1280667
Tracking in the dupe bug, so removing the 50 tracking flag.
tracking-firefox50: + → ---
You need to log in before you can comment on or make changes to this bug.