maphia84.org - doesn't render properly, one frame appears blank (div with "position: absolute" inside an "overflow: auto" doesn't display)

RESOLVED FIXED

Status

RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: gustavo, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020415

doesn't render properly, one frame appears blank, compare with konqueror for
example, wich renders it well

Reproducible: Always
Steps to Reproduce:
1.just go to the website
2.
3.

Actual Results:  you see the problem

Expected Results:  you should see the page properly and be able to read the main
frame wich appears blank with mozilla

Comment 1

17 years ago
Created attachment 69916 [details]
minimal testcase

page renders blank

Comment 2

17 years ago
changing component, OS: All.
Assignee: asa → attinasi
Component: Browser-General → Layout
OS: Linux → All
QA Contact: doronr → petersen
Summary: doesn't render properly, one frame appears blank → doesn't render properly, one frame appears blank (div with "position: absolute" inside an "overflow: auto" doesn't display)
To evangelism, since our rendering is correct.

The body has only absolutely positioned content.  So its height is 0 (all its
content is out-of-flow, and the height is not set, so it acts like height:auto,
sizes based on the height of the content, which is 0, since the content is all
out-of-flow).

Now the body also has overflow:auto, and all the content is overflowing.  So it
should get scrollbars, but its height is 0 so there is nowhere to put the
scrollbars...

IE and Konqueror both size the body to the size of the viewport instead of
sizing it per CSS2, which is why the site looks ok in those browsers.
Assignee: attinasi → doron
Status: UNCONFIRMED → NEW
Component: Layout → US General
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: petersen → zach
Version: other → unspecified

Updated

16 years ago
Summary: doesn't render properly, one frame appears blank (div with "position: absolute" inside an "overflow: auto" doesn't display) → maphia84.org - doesn't render properly, one frame appears blank (div with "position: absolute" inside an "overflow: auto" doesn't display)

Comment 4

16 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us

Comment 5

11 years ago
Site no longer resolves. FIXED by disappearance of site. If there's still a problem and the site has moved, please file a NEW bug on the new site.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.