NullPointerException: Attempt to invoke virtual method 'void org.mozilla.gecko.toolbar.BackButton.setEnabled(boolean)' on a null object reference

RESOLVED FIXED

Status

()

Firefox for Android
General
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: sebastian, Assigned: sebastian)

Tracking

(Blocks: 2 bugs)

unspecified
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec48+)

Details

(crash signature)

Preconditions: Nexus 9, Android N, split screen mode.

After resizing Fennec's screen to be very small (phone-like) I get the following crash:

> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: java.lang.NullPointerException: Attempt to invoke virtual method 'void org.mozilla.gecko.toolbar.BackButton.setEnabled(boolean)' on a null object reference
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at org.mozilla.gecko.toolbar.BrowserToolbarTabletBase.<init>(BrowserToolbarTabletBase.java:57)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at org.mozilla.gecko.toolbar.BrowserToolbarTablet.<init>(BrowserToolbarTablet.java:36)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at org.mozilla.gecko.toolbar.BrowserToolbar.create(BrowserToolbar.java:164)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at org.mozilla.gecko.BrowserApp.onCreateView(BrowserApp.java:290)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at android.app.Activity.onCreateView(Activity.java:5840)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at android.support.v4.app.BaseFragmentActivityHoneycomb.onCreateView(Unknown Source)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at android.support.v4.app.FragmentActivity.onCreateView(Unknown Source)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at android.view.LayoutInflater.createViewFromTag(LayoutInflater.java:777)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at android.view.LayoutInflater.createViewFromTag(LayoutInflater.java:727)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at android.view.LayoutInflater.rInflate(LayoutInflater.java:858)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at android.view.LayoutInflater.rInflateChildren(LayoutInflater.java:821)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at android.view.LayoutInflater.rInflate(LayoutInflater.java:861)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at android.view.LayoutInflater.rInflateChildren(LayoutInflater.java:821)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at android.view.LayoutInflater.rInflate(LayoutInflater.java:861)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at android.view.LayoutInflater.rInflateChildren(LayoutInflater.java:821)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at android.view.LayoutInflater.rInflate(LayoutInflater.java:861)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at android.view.LayoutInflater.rInflateChildren(LayoutInflater.java:821)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at android.view.LayoutInflater.inflate(LayoutInflater.java:518)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at android.view.LayoutInflater.inflate(LayoutInflater.java:426)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at android.view.LayoutInflater.inflate(LayoutInflater.java:377)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at com.android.internal.policy.PhoneWindow.setContentView(PhoneWindow.java:400)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at android.app.Activity.setContentView(Activity.java:2387)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at org.mozilla.gecko.GeckoApp.onCreate(GeckoApp.java:1276)
> 03-15 10:37:54.145  5178  5178 E GeckoCrashHandler: 	at org.mozilla.gecko.BrowserApp.onCreate(BrowserApp.java:592)
Crash Signature: java.lang.NullPointerException: Attempt to invoke virtual method ''void org.mozilla.gecko.toolbar.BackButton.setEnabled(boolean)'' on a null object reference at org.mozilla.gecko.toolbar.BrowserToolbarTabletBase.<init>(BrowserToolbarTabletBase.java)
Crash Signature: java.lang.NullPointerException: Attempt to invoke virtual method ''void org.mozilla.gecko.toolbar.BackButton.setEnabled(boolean)'' on a null object reference at org.mozilla.gecko.toolbar.BrowserToolbarTabletBase.<init>(BrowserToolbarTabletBase.java) → [@ java.lang.NullPointerException: Attempt to invoke virtual method ''void org.mozilla.gecko.toolbar.BackButton.setEnabled(boolean)'' on a null object reference at org.mozilla.gecko.toolbar.BrowserToolbarTabletBase.<init>(BrowserToolbarTabletBase.java)]

Comment 1

2 years ago
Is this reproducible? How hard would it be to fix this?
tracking-fennec: --- → ?
Flags: needinfo?(s.kaspari)
I think this should be fixed by the changes we did to stop crashing in split screen mode. I'll do some testing.
Assignee: nobody → s.kaspari
Status: NEW → ASSIGNED
Flags: needinfo?(s.kaspari)
tracking-fennec: ? → 48+
Yep, can't reproduce this anymore. And in crash stats the last version is 47 too.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.