'Page/Frame Source' doesn't show actual source code of current page

VERIFIED DUPLICATE of bug 60426

Status

()

--
minor
VERIFIED DUPLICATE of bug 60426
17 years ago
2 months ago

People

(Reporter: alexander.zink, Assigned: kmcclusk)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If I load a page which makes use of the JavaScript function document.write, the
page's content becomes dynamically changed.
Now there is now way to see the actual source code of the page I'm just working
with. Both commands Page/Frame Source _only_ show the original page which had
been downloaded, but _not_ the page I'm just seeing in Navigator (it may be a
completely differente content!)

I suggest to have at least an additonal option to see the _actual_ source code
of the page/frame. This functionality may be included in the Source Code viewer
or - even better - as an additional fly-out in the View menu and page's/frame's
context menu.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 60426 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
See DOM inspector
vrfy
Status: RESOLVED → VERIFIED
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.