Font renders at incorrect size with SVG

RESOLVED WONTFIX

Status

()

Core
SVG
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: russell.hay, Unassigned)

Tracking

({reproducible})

40 Branch
x86
Mac OS X
reproducible
Points:
---

Firefox Tracking Flags

(firefox48 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8730830 [details]
2-color.svg

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150812163655

Steps to reproduce:

The Repro step is super easy, just open the attached SVG file in firefox and in safari and compare the "HIC SUNT" text at the top.  The SVG was originally generated with Adobe Illustrator


Actual results:

When opened in Firefox "HIC SUNT" does not span the entire width of the shield underneath.  When opened in Safari, "HIC SUNT" spans the entire width of the shield.


Expected results:

The text should render the full width of the shield as originally intended and as shown in Safari.

Updated

2 years ago
Component: Untriaged → SVG
Product: Firefox → Core
Able to reproduce in 48 Nightly.
Status: UNCONFIRMED → NEW
Has STR: --- → yes
status-firefox48: --- → affected
Ever confirmed: true
Keywords: regressionwindow-wanted, reproducible
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86
The attached file use SVG fonts which we do not and will not support. Safari is the only mainstream browser that still supports SVG fonts: http://caniuse.com/#search=SVG%20font
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.