[ESLint] Fix ESLint issues in devtools/client/webconsole/test/browser_bug_638949_copy_link_location.js

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
3 years ago
6 months ago

People

(Reporter: linclark, Unassigned, Mentored, NeedInfo)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [btpp-backlog])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
If you haven’t contributed to Firefox before, follow the steps here to set up your environment: https://developer.mozilla.org/en-US/docs/Tools/Contributing#Getting_set_up

Then, automatically configure ESLint to work with the Firefox specific rules by following the instructions here: https://wiki.mozilla.org/DevTools/CodingStandards

Then you can see the issues that need to be fixed by running

> eslint --no-ignore devtools/client/webconsole/test/browser_bug_638949_copy_link_location.js
(Reporter)

Updated

3 years ago
Blocks: 1256948
Priority: -- → P3
(Reporter)

Updated

3 years ago
Whiteboard: [btpp-backlog]

Comment 1

3 years ago
Created attachment 8739372 [details] [diff] [review]
1256774.patch

Hi,please review my patch
Attachment #8739372 - Flags: review?(jlaster)
Hi simplyblue, linclark would be a better reviewer.
Flags: needinfo?(lclark)
(Reporter)

Comment 3

3 years ago
Comment on attachment 8739372 [details] [diff] [review]
1256774.patch

Review of attachment 8739372 [details] [diff] [review]:
-----------------------------------------------------------------

This one looks good to. Feel free to add the checkin-needed keyword
Attachment #8739372 - Flags: review?(jlaster) → review+
(Reporter)

Updated

3 years ago
Flags: needinfo?(lclark)
Duplicate of this bug: 1270053
Assignee: nobody → bmanojkumar24
Status: NEW → ASSIGNED
When I test this out with the patch applied, I'm still seeing some eslint errors:

  29:3   error    content is a possible Cross Process Object Wrapper (CPOW)                 mozilla/no-cpows-in-tests
  45:3   error    'goUpdateCommand' is not defined                                          no-undef
  50:9   error    'waitForContextMenu' is not defined                                       no-undef
  57:3   error    content is a possible Cross Process Object Wrapper (CPOW)                 mozilla/no-cpows-in-tests
  75:3   error    'goUpdateCommand' is not defined                                          no-undef
  80:18  error    'promise' is not defined                                                  no-undef
  85:5   error    'goDoCommand' is not defined                                              no-undef
  96:9   error    'waitForContextMenu' is not defined                                       no-undef

Can you please take a look?  This is when running: ./mach eslint --no-ignore devtools/client/webconsole/test/browser_bug_638949_copy_link_location.js

For the no-cpows-in-tests issue you'll need to wrap any calls to content inside a ContentTask.spawn, i.e.

  ContentTask.spawn(gBrowser.selectedBrowser, {}, function* () {
    content.console.log("bug 638949");
  });
Flags: needinfo?(bmanojkumar24)
Assignee: bmanojkumar24 → nobody
Status: ASSIGNED → NEW
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX

Updated

6 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.