EventTarget::DispatchEvent() should be implemented in EventTarget.cpp rather than nsINode.cpp

RESOLVED DUPLICATE of bug 684208

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 684208
2 years ago
2 years ago

People

(Reporter: masayuki, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox48 affected)

Details

I find EventTarget::DispatchEvent() in nsINode.cpp:
http://mxr.mozilla.org/mozilla-central/source/dom/base/nsINode.cpp?rev=7661eb78c9ac#2812

However, I was looking for it in EventTarget.cpp. So, for preventing the confusion, we should move it from nsINode.cpp to EventTarget.cpp.
This is being fixed in bug 684208
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 684208
You need to log in before you can comment on or make changes to this bug.