If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox 45.0 Slow Startup and very slow and very lagging. Using To Much RAM WIndows 10

RESOLVED INCOMPLETE

Status

()

Toolkit
Startup and Profile System
RESOLVED INCOMPLETE
2 years ago
a year ago

People

(Reporter: klinks88, Unassigned, NeedInfo)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160303134406

Steps to reproduce:

I left click to open Firefox from task bar when Firefox is opening it is very slow and lagging.
1. Completely uninstall Firefox
2. Reinstall Firefox
3. only have 3 add-ons install 


Actual results:

Firefox opens slow startup and running very slow and very lagging. Using to Much RAM in Windows 10 


Expected results:

Everything should be opening and working fine without any slowness and startup and lagging.

Comment 1

2 years ago
Is it reproducible:
1) in safe mode:
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

2) with a fresh profile:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(kardamp)
(Reporter)

Comment 2

2 years ago
1. Try in safe mode no improvement.

2. Still no difference with fresh profile.


Explicit Allocations

210.90 MB (100.0%) ++ explicit

Other Measurements

4,095.94 MB (100.0%) -- address-space
├──3,160.88 MB (77.17%) ── free [296]
├────676.50 MB (16.52%) ++ commit
└────258.56 MB (06.31%) ++ reserved
Flags: needinfo?(kardamp)

Comment 3

2 years ago
Could you start with a fresh profile then save and attach the memory log to the bug report, please.
Flags: needinfo?(kardamp)
Whiteboard: [MemShrink]
(Reporter)

Comment 4

2 years ago
This is with new profile


Main Process
Explicit Allocations

102.52 MB (100.0%) ++ explicit

Other Measurements

4,095.94 MB (100.0%) -- address-space
├──3,402.65 MB (83.07%) ── free [227]
├────418.51 MB (10.22%) -- commit
│    ├──174.59 MB (04.26%) -- private
│    │  ├──165.88 MB (04.05%) ── readwrite [730]
│    │  └────8.71 MB (00.21%) ++ (6 tiny)
│    ├──173.07 MB (04.23%) -- image
│    │  ├──109.22 MB (02.67%) ── execute-read [130]
│    │  ├───55.54 MB (01.36%) ── readonly [294]
│    │  └────8.31 MB (00.20%) ++ (2 tiny)
│    └───70.86 MB (01.73%) -- mapped
│        ├──62.51 MB (01.53%) ── readonly [36]
│        └───8.35 MB (00.20%) ++ (2 tiny)
└────274.77 MB (06.71%) -- reserved
     ├──252.68 MB (06.17%) ── private [740]
     └───22.09 MB (00.54%) ++ (2 tiny)
Flags: needinfo?(kardamp)

Comment 5

2 years ago
Hi,

I have tested this on Windows 10 x64 with Nightly 48(2016-03-20) and FF45 and I can't reproduce it. Do you see this issue only in Firefox version 45, or did you notice it in older versions? If you open Firefox in other way you have the same results? 
Please download the Firefox Nightly from here: https://nightly.mozilla.org/ and retest the problem.
Component: Untriaged → Startup and Profile System
Flags: needinfo?(kardamp)
Product: Firefox → Toolkit
(Reporter)

Comment 6

2 years ago
The funny thing is I have tried the Firefox browser in the desktop running Windows 7 and Windows 10. I tried it on desktop with I5 processor 8 GB ram and AMD FX-8120 processor with 8 GB. I am only having issue with my laptop with Intel i5 processor 8 GB ram. I have tried creating new profile, tried different version of Firefox. Not the Nightly build yet. Have tried the Beta version same issue in the laptop without any extensions.

1. Firefox opens up quickly right away.
2. address bar is not slow skipping any letters when I am typing website addresses.
3. I can open many tabs and keep it open without any lags, slowness or any hiccups.
Flags: needinfo?(kardamp)
It's possible this is a graphics issue. The memory usage provided looks reasonable, but getting a full report might be helpful.

klinks88, can you copy and paste the output from about:support on your laptop and also attach a full memory report (about:memory -> "Measure and save...")?
Flags: needinfo?(kardamp)
klinks88, can you provide the information requested in comment 7? We can't make progress without that. Thank you.
I will close this bug due to lack of response from the reporter. Please reopen if you have the data requested in comment 7. Thank you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.