Closed Bug 1257090 Opened 4 years ago Closed 4 years ago

Crash [@ mozilla::dom::AudioContext::Suspend] with cycle collection and sync XHR

Categories

(Core :: Web Audio, defect, P1, critical)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1255618
Tracking Status
firefox48 --- affected

People

(Reporter: jruderman, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, testcase)

Attachments

(2 files)

No description provided.
Karl -- Can you take a look at this?  Jesse just found it.
Rank: 15
Flags: needinfo?(karlt)
Priority: -- → P1
I didn't work out how to run the testcase:

% python2.7 funfuzz/dom/automation/domInteresting.py build ~/tmp/h.html 
Traceback (most recent call last):
  File "funfuzz/dom/automation/domInteresting.py", line 46, in <module>
    import createCollector
  File "/mnt/ssd1/karl/moz/funfuzz/util/createCollector.py", line 12, in <module>
    from Collector.Collector import Collector
  File "/mnt/ssd1/karl/moz/FuzzManager/Collector/Collector.py", line 29, in <module>
    import requests
ImportError: No module named requests

% mkdir -p px/df/extensions
% cp funfuzz/dom/automation/constant-prefs.js px/df/prefs.js  
% echo ~/moz/funfuzz/dom/extension/ > px/df/extensions/domfuzz@squarefree
% dev/obj-opt/dist/bin/firefox -profile `pwd`/px/df ~/tmp/h.html    

Connects remotely to existing browser.

% dev/obj-opt/dist/bin/firefox -profile `pwd`/px/df -no-remote ~/tmp/h.html

JavaScript error: file:///home/karl/tmp/h.html, line 11: ReferenceError: fuzzPriv is not defined

Jesse: This report looks like bug 1255618.
Do you know whether you were reproducing before or after this?
https://bugzilla.mozilla.org/show_bug.cgi?id=1255618#c17
Flags: needinfo?(karlt) → needinfo?(jruderman)
> ImportError: No module named requests

I guess now that funfuzz depends on FuzzManager, you have to install FuzzManager's dependencies. Even when using the parts of funfuzz that don't use FuzzManager, or the parts of FuzzManager that don't use those dependencies :/

> Connects remotely to existing browser.

Oops, forgot about -no-remote, which is needed on platforms other than Mac. Looks like you found it though.

> ReferenceError: fuzzPriv is not defined

Huh, so installing the extension didn't work? (You might have been missing a ".com" after "domfuzz@squarefree"?)

> Jesse: This report looks like bug 1255618.

I can't reproduce any more on mozilla-central. Feel free to mark WFM/FIXED/DUP as you feel is most appropriate :)

> Do you know whether you were reproducing before or after this?
> https://bugzilla.mozilla.org/show_bug.cgi?id=1255618#c17

I don't remember the exact version I was testing.
Flags: needinfo?(jruderman)
Thanks, Jesse!
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1255618
You need to log in before you can comment on or make changes to this bug.