No release notes, Bugzilla entry, or download link for Lightning 4.0.7

RESOLVED WORKSFORME

Status

Calendar
Website
RESOLVED WORKSFORME
2 years ago
6 months ago

People

(Reporter: Tristan Miller, Unassigned)

Tracking

Lightning 4.0.7

Details

(Reporter)

Description

2 years ago
Today Thunderbird automatically upgraded my Lightning installation to 4.0.7.  However, there appears to be no web presence whatsoever for this version.  It doesn't exist in the "Version" drop-down field on this Bugzilla and there is no changelog or download link posted at <https://developer.mozilla.org/en-US/docs/Mozilla/Calendar/Calendar_Versions>.

I don't recall this problem occurring for any prior upgrade (though maybe it did and I didn't notice).  Wouldn't it be better to make sure all aspects of the web presence are updated *before* pushing the release to the automatic update system, so that people can read the release notes and properly file bug reports for it?

Comment 1

2 years ago
I can't speak to the lightning pieces, but for Thunderbird the web redirects for Help | Release note were delayed. They were done this morning but haven't yet fully propagated to send you to https://www.mozilla.org/en-US/thunderbird/38.7.0/releasenotes/

Comment 2

2 years ago
Lightning package is shipped as a part of Thunderbird since Thunderbird 38. 

I assume you got updated to Thunderbird 38.7 today. The included Lightning package automatically gets a version number that matches the Thunderbird version, i.e. Thunderbird 38.0 contained Lightning 4.0.0, Thunderbird 38.1 contained Lightning 4.0.1, ... and Thunderbird 38.7 contains Lightning 4.0.7.

I am not aware of any Lightning related changes since 4.0.6, therefore Lightning 4.0.6 and Lightning 4.0.7 are identical (except version number). No changes, no changelog.
(Reporter)

Comment 3

2 years ago
I wasn't aware of this automatic change in version numbering despite the lack of any changes or formal release.  Maybe there are good reasons for it but I think I've demonstrated that it can also lead to some confusion by those looking to read changelogs or file bug reports.  Perhaps some sort of explanatory note could be added to <https://developer.mozilla.org/en-US/docs/Mozilla/Calendar/Calendar_Versions>?

Updated

2 years ago
Version: unspecified → Lightning 4.0.7
The most important changes for Lightning have been included in the Thunderbird release notes for the last releases. The Calendar Versions page is mostly up-to-date with a link to all the bug fixes/feature included in the release bases on the "Target" version field. Resolving as WORKSFORME. If there are specific ideas how to further improve the situation, please file a new issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.