Advanced->Update tab is completely blank

RESOLVED FIXED in Thunderbird 48.0

Status

defect
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: psychonaut, Assigned: Paenglab)

Tracking

38 Branch
Thunderbird 48.0

Thunderbird Tracking Flags

(thunderbird46 wontfix, thunderbird47 fixed, thunderbird48 fixed, thunderbird_esr4546+ fixed)

Details

Attachments

(2 attachments)

The Advanced->Update tab in Thunderbird 38.7.0 is completely blank (see attached screenshot).  This looks very strange.  Is something supposed to be there?  If not, perhaps the tab should be removed, or else a message to the effect of "This space deliberately left blank" should be added.

Problem occurs with Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.7.0.  Haven't tested any other platform.
(In reply to Tristan Miller from comment #0)
>...
> Problem occurs with Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101
> Thunderbird/38.7.0.  Haven't tested any other platform.

WFM on win7. 
Does it also happen if Thunderbird started in safe mode?
And Can you try another OS?
Yes, the problem also occurs in safe mode.  Haven't tried any other OS but may do so if the opportunity presents itself.
It occurs to me that maybe the problem was caused by my distribution (openSUSE 13.2), which provides the packages from which I normally install Thunderbird.  Perhaps they've removed whatever's in the Update tab to prevent people from updating Thunderbird my means other than their own packages.
You can test that theory by installing from http://getthunderbird.com/
Flags: needinfo?(psychonaut)
Yeah, the version installed from http://getthunderbird.com/ doesn't have a blank Update tab in the Preferences.  I'll file a report on the downstream issue tracker and post a link to it here.  (Hope it's not too presumptive of me to mark the current report as RESOLVED/INVALID now.)
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(psychonaut)
Resolution: --- → INVALID
(In reply to Tristan Miller from comment #5)
> (Hope it's not too presumptive of
> me to mark the current report as RESOLVED/INVALID now.)

that's perfect. thanks. And yes, post the link to the report here
Downstream bug report: https://bugzilla.novell.com/show_bug.cgi?id=971584
Reopening; the downstream packagers think it's a Mozilla issue, since Thunderbird itself provides the compile-time option for disabling the updater (ac_add_options --disable-updater).  Using this option ought to remove the entire Update tab, or (if the Update tab is used by other components as well) it should replace the updater options in this tab with a message that the updater has been disabled.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Especially Thunderbird already removes the update preferences if the updater is missing:
http://mxr.mozilla.org/comm-release/source/mail/components/preferences/advanced.xul#95
Now it just needs an additional condition to remove the whole tab if it ends up empty.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Posted patch 1257160.patchSplinter Review
This patch removes the Update tab completely when ac_add_options --disable-updater is set.

I moved the ifdefs a bit to remove the comments to the update tab also. I think it looks weird when there are comments to a non-existent feature.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8731832 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8731832 [details] [diff] [review]
1257160.patch

Review of attachment 8731832 [details] [diff] [review]:
-----------------------------------------------------------------

It's a bit problematic to hide tabs, as it might send people of on a wild goose chase. I suppose it's ok though. r=mkmelin
Attachment #8731832 - Flags: review?(mkmelin+mozilla) → review+
http://hg.mozilla.org/comm-central/rev/1d816fb98113
Status: ASSIGNED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 48.0
Thanks, bug 1135294 comment 6 :)
Kent, what do you think, do we want this for 45esr?
Flags: needinfo?(rkent)
Richrd: yes, but not until a point release.
Flags: needinfo?(rkent)
Comment on attachment 8731832 [details] [diff] [review]
1257160.patch

[Approval Request Comment]
User impact if declined: empty tab can irritating users
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): should be low
Attachment #8731832 - Flags: approval-comm-esr45?
Attachment #8731832 - Flags: approval-comm-beta?
Attachment #8731832 - Flags: approval-comm-aurora?
Attachment #8731832 - Flags: approval-comm-aurora? → approval-comm-aurora+
Attachment #8731832 - Flags: approval-comm-esr45? → approval-comm-esr45+
Attachment #8731832 - Flags: approval-comm-beta? → approval-comm-beta-
You need to log in before you can comment on or make changes to this bug.