Closed Bug 125723 Opened 18 years ago Closed 17 years ago

[FIX]'View: Message Source' should open in same window as 'View: Page Source'

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3, minor)

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.2beta

People

(Reporter: jim.avera, Assigned: bzbarsky)

References

()

Details

Attachments

(1 file, 1 obsolete file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020206
BuildID:    

If an e-mail message source is viewed, a right mouse-click
brings up a menu with various options.  Some of the options
seem inappropriate, or are completely non-functional:

* View Page Source
     (probably inappropriate - the user is already viewing the source)
* Bookmark this page
     (definately inappropriate)
* Save Page As...
     (should work but is broken - nothing happens) 

Reproducible: Always
Steps to Reproduce:
1.View an e-mail message
2.View->Message Source (or Ctrl-U)
3.Put mouse in the message-source window and right-click
4.Select Save Page As... 

Actual Results:  Nothing happens

Expected Results:  Save dialog should appear for "Save Page As...".

Also, some of the other options are probably inappropriate
for viewing an e-mail message source and should not appear.
QA Contact: esther → olgam
I can 'Save Page As' from Message Source context menu.
I cc: browser person to look at this.
There is bug 75338 for context menu issues on Browser. (Source View page is a
Browser page). If you consider that this one might be part of that meta bug,
mark as dup.
I would think it would it be appropriate to have a "View Message Source" open in 
the exact same window that the "View Page Source" does for the browser. So the 
context menu and available functionality would be the same for both.
Thanks, Jennifer. I change summary to reflect this: 'View: Message Source'(for a
message) should open in same window 'View: Page Source' (as browser page). Then,
the context menu for 'Message source' should be the same as the browser 'Page
Source' context menu.
Previous summary: 'Broken and inappropriate items in  right-click menu for
msg-source screen'.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Broken and inappropriate items in right-click menu for msg-source screen → 'View: Message Source' should open in same window as 'View: Page Source'
Neil, all we'd need to do here is to make the view-source window not barf on the
content-type mail channels have, right?  And then just use it?
Blocks: 64933, 116196, 126120
OS: Linux → All
Hardware: PC → All
bz, sounds good to me.
*** Bug 153538 has been marked as a duplicate of this bug. ***
Depends on: 77337
Tested that patch now.  Works as advertised on TV.
Attachment #97716 - Flags: review+
Comment on attachment 97716 [details] [diff] [review]
patch (untested; my mailnews is all confused at the moment)

r=neil@parkwaycc.co.uk
Nice work, bz. Faster too!
Comment on attachment 97932 [details] [diff] [review]
same s/tab/spaces/, remove incorrect comment.

carrying the r=neil
Attachment #97932 - Flags: review+
Comment on attachment 97716 [details] [diff] [review]
patch (untested; my mailnews is all confused at the moment)

sr=jag
Attachment #97716 - Flags: superreview+
mine.
Assignee: sspitzer → bzbarsky
Priority: -- → P3
Summary: 'View: Message Source' should open in same window as 'View: Page Source' → [FIX]'View: Message Source' should open in same window as 'View: Page Source'
Target Milestone: --- → mozilla1.2beta
Good stuff
Comment on attachment 97932 [details] [diff] [review]
same s/tab/spaces/, remove incorrect comment.

sr=sspitzer

my only concern is what happens we finally break apart mail and browser?

I guess we'll have to figure that out when the time comes.  I'll add it to
http://www.mozilla.org/mailnews/minotaur/index.html
Attachment #97932 - Flags: superreview+
> my only concern is what happens we finally break apart mail and browser?

Um, you are already using a *browser* window - this just uses a different one.
fixed for 1.2b.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Verified build 2002091204.
Status: RESOLVED → VERIFIED
Blocks: 111164
No longer blocks: 126120
*** Bug 126838 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.