Closed Bug 12573 Opened 21 years ago Closed 21 years ago

Migrated prefs.js: folder pane does not open folders

Categories

(MailNews Core :: Backend, defect, P3)

Other
Linux
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: fenella, Assigned: sspitzer)

Details

Linux RedHat 6.0 (1999-08-25-08 M10), (1999-08-25-13 M10)
1.  Run ./netscape using nova 4.7 using account, qatest38.
2.  Read mail/news on Nova 4.7, this creates a preferences.js in the
    ../qatest38/.netscape/ directory
3.  Copy preferences.js to the ../.mozilla/qatest38/ directory and name it
    prefs.js
4.  Run ./apprunner
5.  Open Messenger from Task
6.  The folder pane shows:
	news.mozilla.org
	qatest38 on mail-5
	news
7.  click on any one of them
Actual result:  No folders is displayed in the thread pane
Expected result:  folders should be displayed in the thread pane when selecting
a mail/news server.

In the console, error is displayed:

an exception occurred trying to load "rdf:xpinstall-update-notifier":
[Exception... "Component returned failure code: 0x80510003
[nsIRDFService.GetDataSource]"  nsresult: "0x80510003 (<unknown>)"  location:
"JS frame ::
file:////home/gor/seamonkey/package/chrome/sidebar/content/default/flash.xul ::
Init :: line 79"  data: no]

I got crashes on windows using the latest build. Need more testing...

Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → INVALID
Summary: Migrated prefs.js: folder pane does not open folders → Migrated prefs.js: folder pane does not open folders
Copying the prefs file from 4.x to 5.0 by hand is not the right way to migrate
prefs. You should run apprunner -installer and then apprunner lets you choose a
4.x profile to migrate, and it does all the migration.
hmm, Seth told us that this was another way to migrate prefs.
Fenella -go ahead and try this with apprunner -installer.
I tried using ./apprunner -install, it created an empty prefs.js file.  I asked
Scott M., he said that -install does not work on Linux yet.  He told me to file
this bug as described.
Status: RESOLVED → REOPENED
Must be my misunderstanding. Reopening and reassigning to the all knowing
sspitzer.
Resolution: INVALID → ---
Assignee: phil → sspitzer
Status: REOPENED → NEW
(Seth - Bindu also ran into a problem with empty folders (she's using Win32)
after the migration - if this is a separate bug, I'll file it.)
(Bindu - can you attach your 4.x prefs file for perftest account here?)
Status: NEW → ASSIGNED
-installer doensn't work on linux.  For linux, you need to do what the reporter
did, copy and rename your 4.x prefs file.

the flash.xul message on the console has nothing to with this bug.  (but you
should log a bug against that error message, since something must not be right.)

accepting bug.
I'm thinking this may be fixed now.
alecf and I both landed a bunch of changes.
can you try again on the 8/27 build?
it works for me right now on my tree, but I'll wait until you confirm tomorrow.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
Resolving fixed. Please verify.
Status: RESOLVED → VERIFIED
Linux (1999-09-14-09-M11)

The scenario described in this bug report no longer applies.  We can now use the
installer to migrate prefs.js using
./mozilla-apprunner.sh -installer
It works using installer and I am able to open folders. Mark it verified.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.