If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Audio/video synchronization issues with long 60 fps YouTube videos

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Pascal Laprade, Unassigned)

Tracking

45 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160303134406

Steps to reproduce:

When watching a somewhat long video on YouTube in 720p60 (or any other 60fps video mode) -- like this one, for instance : https://www.youtube.com/watch?v=7O0d2UGxET8 -- a desynchronization between the audio and video will slowly build up, to the point where the video becomes unwatchable after a certain time. For the mentionned video above, that point is around 6 minutes in, if you do not skip the video playback to there manually. It probably starts a little sooner, but it is not quite as noticeable as when the gameplay starts, where the delay is about one second late for the video compared to the audio track.

Reloading the page solves the problem temporarily, but after some time, the desync happens again (or becomes noticeable, depending on the way one views things).

This problem does not happen when watching non-60fps videos, be they HD (720p or better) or SD (like 480p). This issue leads me to watch these videos in 480p, which is not really nice.

I also tested the videos on another browser (Safari), and I noticed no desync for the whole duration of the video.

It is not bound to this particular video, just to be clear, but rather to all lengthy 60 fps videos (at least on YouTube). I just had enough today and decided to fill a bug.


Actual results:

As described in the steps to reproduce, as time goes into the watching of a video, the audio and video slowly becomes desynchronized.


Expected results:

There should be no delay between the audio and video.
(Reporter)

Updated

2 years ago
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64

Updated

2 years ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core

Comment 1

2 years ago
A recent bug (bug 1236112) has been fixed in FF48 about 60fps video.
Could you test with Nightly maybe? https://nightly.mozilla.org/
Flags: needinfo?(laprade.p)
(Reporter)

Comment 2

2 years ago
I rewatched the video I provided above with Nightly (48.0a1 (2016-03-17)) and the problem did not happen this time. I'll use the same Nightly in the few following days with other videos to confirm!
(Reporter)

Comment 3

2 years ago
After using Nightly in the last days, the problem did not appear on any video I watched. I'm guessing it might have been solved at the same time as the screen shaking bug you referred me to. I'll keep using version 48, then! Thank you!
Flags: needinfo?(laprade.p)

Comment 4

2 years ago
Ty for the feedback. Remember Nighty is an alpha version, so it could be unstable for daily use. 
Besides that, feel free to reopen the bug if the issue is back.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.