Closed Bug 125742 Opened 23 years ago Closed 17 years ago

View | Sidebar in Composer brings browser window to foreground

Categories

(SeaMonkey :: Sidebar, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME
Future

People

(Reporter: Brade, Unassigned)

References

Details

(Keywords: helpwanted)

I opened a new Composer window.
I then chose View > Sidebar menu item.
The sidebar appeared and my browser window came to the front.

Expectation:  Browser window shouldn't move when show/hiding sidebar.

If it's relevant, the History tab is the active tab in the sidebar.
Also, note: subsequent toggles of that menu item don't move browser window but
creating a new composer window and doing the steps again do show the problem.
hmmm..I can't reproduce this...I'm using 2/14 build.

when I use F9 to open the sidebar, the browser window stays
in the background.
try making History the active tab?
confirming....only happens when you click on History in the sidebar or
History is the active sidebar tab.
Is this causing the first history tab (in the browser window) to gain focus?

<http://lxr.mozilla.org/seamonkey/source/xpfe/components/history/resources/history.js#105>
105 gHistoryOutliner.focus();

Over to history folks for a look.

Assignee: sgehani → blaker
Component: Sidebar → History: Global
OS: Mac System 9.x → All
QA Contact: sujay → claudius
Hardware: Macintosh → All
This will also happen for bookmarks, but I don't think just removing or
special-casing the focus calls is the correct fix.  All html sidebar panels
could do this, so I think sidebar needs to devise a way to deal with it in general.
Assignee: blaker → sgehani
Component: History: Global → Sidebar
QA Contact: claudius → sujay
Keywords: helpwanted
Target Milestone: --- → Future
This bug problem looks like it is related to the focus bug 122765, which should
be fixed in 3-7 builds.
Blocks: 88810
Product: Browser → Seamonkey
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060101 SeaMonkey/1.5a

Does anyone who tested this earlier still see this?
Assignee: samir_bugzilla → sidebar
QA Contact: sujay
per comment 7
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.