Push messages don't trigger pop-up notification (associated with a perhaps corrupt profile)

RESOLVED WORKSFORME

Status

()

Core
DOM: Push Notifications
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: rpapa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: btpp-followup-2016-04-18)

Issue seen on Nightly, Release and on both Windows, OSX:
Push notification don't trigger pop-up notification (though push notification appears delivered in web console).

Seems to be associated with a (perhaps corrupt?) profile, but don't yet have STR to trigger the condition yet.  Once profile has this issue, it is 100% reproducible with that profile.

workaround: create a new profile

If you see this issue, pls attach your profile.


STR

setup:
start browser with new/existing profile
open: about:config
set: dom.push.loglevel=debug (instead of 'off')
open: Tools > WebDeveloper > BrowserConsole

open: https://people.mozilla.org/~ewong2/push-notification-test/
choose: "service-worker.js"
click: "register Service Worker"
click: "subscribe to push"
observe push registration in console
click: "Always Receive Notifications" (in pop-up window)

 
click: "XHR to webpush app-server
wait for push notification pop-up


SHOULD SEE:
pop-up notification

ACTUAL
message appears to be delivered in console, but pop-up notification never triggers
QA Contact: rpappalardo
William, is this a notifications issue?

Richard, once you get an STR (or maybe you can share this profile?) please let us know.
Flags: needinfo?(wchen)
Whiteboard: btpp-followup-2016-04-18
(In reply to Andrew Overholt [:overholt] from comment #1)
> William, is this a notifications issue?
> 
> Richard, once you get an STR (or maybe you can share this profile?) please
> let us know.

Sure, Andrew, np.  Haven't seen it in awhile, but as soon as I do, I attach the profile and STR if I can.
having seen this in awhile so, closing for now
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
From the symptoms described it's not clear that this is an issue with notifications because we don't explicitly depend on profile data to show notifications. We can look into this again when we can reproduce.
Flags: needinfo?(wchen)
You need to log in before you can comment on or make changes to this bug.