Click event happens on old element after I release mouse (mouseup) over another element on http://www.thedailybeast.com

RESOLVED DUPLICATE of bug 1187591

Status

()

RESOLVED DUPLICATE of bug 1187591
3 years ago
a year ago

People

(Reporter: arni2033, Unassigned, NeedInfo)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 affected)

Details

(Whiteboard: [parity-Chrome], URL)

(Reporter)

Description

3 years ago
>>>   My Info:   Win7_64, Nightly 48, 32bit, ID 20160317030235
STR:
1. Open
   http://www.thedailybeast.com/articles/2016/01/10/are-russians-and-ukrainians-the-same-people.html
2. Scroll a bit down so that "READ THIS. list" became fully visible
3. Make sure that the 1st item in that list is only partially grayed out.
4. Hover mouse over the text in the 2nd item in that list
5. Hold left mouse button
6. Move mouse to the left, to the article's text (move it away from the 2nd item)
7. Release left mouse button

AR:  The 2nd item is clicked. If I set breakpoint on 'click' event, it fires with
     e.explicitOriginalTarget == the 2nd item.
     If I add attribute [onclick="console.log('fake click')"] to the 2nd item (<a> element),
     then I see that message in console.

ER:  No click, because I moved mouse away. Just like in GoogleChrome browser

Note:
 A friend of mine (who is "regular joe" Mozilla is aiming to) was very disappointed when I showed
 him several cases when Firefox fails to do this trick - "mousedown-drag-mouseup to cancel click" 
 He's using GoogleChrome btw
Olli, WDYT?
Flags: needinfo?(bugs)
Whiteboard: [parity-Chrome] → [parity-Chrome] btpp-followup-2016-04-18
Same story as in bug 1257816. there's a `overflow: hidden;` on `.sidebar .rtl-list .rtl-item h3, .sidebar .rtl-list .rtl-item h4`. Without that, dragging out does not fire the click event. This is tracked in bug 1187591.
Depends on: 1187591
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Whiteboard: [parity-Chrome] btpp-followup-2016-04-18 → [parity-Chrome]
Duplicate of bug: 1187591
You need to log in before you can comment on or make changes to this bug.