Tracking protection blocks Google+ "Log in with Google"

RESOLVED DUPLICATE of bug 1273531

Status

()

RESOLVED DUPLICATE of bug 1273531
3 years ago
26 days ago

People

(Reporter: emailmeat, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160303134406

Steps to reproduce:

Open this page in a private tab and use the red button to try to log in with Google+: http://forum.outerspace.com.br/index.php?login/


Actual results:

The resource at "https://plus.google.com/js/client:plusone.js" was blocked because tracking protection is enabled.


Expected results:

Tracking protection shouldn't prevent users from logging in to their accounts.
(Reporter)

Updated

3 years ago
Summary: Tracking protection blocks Google+ "Login with Google" → Tracking protection blocks Google+ "Log in with Google"

Updated

3 years ago
Component: Untriaged → Private Browsing

Comment 1

3 years ago
The new component for Tracking Protection is Toolkit::Safe Browsing now.
Blocks: 1176480
Component: Private Browsing → Safe Browsing
Product: Firefox → Toolkit

Updated

3 years ago
Blocks: 1101005
No longer blocks: 1176480
Component: Safe Browsing → Tracking Protection
Product: Toolkit → Firefox
Version: 45 Branch → unspecified
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1273531
(Reporter)

Comment 3

2 years ago
(In reply to François Marier [:francois] from comment #2)
> 
> *** This bug has been marked as a duplicate of bug 1273531 ***

François, I reported this bug months before the other report. Why is it mine that was marked as a duplicate?
(In reply to Hide my Email from comment #3)
> François, I reported this bug months before the other report. Why is it mine
> that was marked as a duplicate?

That's a technical limitation of Bugzilla: we can't merge two bugs that are about the same problem. Instead, we have to mark one as a duplicate of another one. Of course, both reports are available and link to one another so we can use both examples to test this problem.
Blocks: 1470298
No longer blocks: 1101005
You need to log in before you can comment on or make changes to this bug.