[RR]Crash when switching from HTML source to Normal view or saving changes in HTML Source View

VERIFIED DUPLICATE of bug 141054

Status

()

Core
CSS Parsing and Computation
--
critical
VERIFIED DUPLICATE of bug 141054
17 years ago
16 years ago

People

(Reporter: K'Trina Medina, Assigned: dbaron)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE-)

(Reporter)

Description

17 years ago
Crash in Composer when switching from HTML Source to Normal view or saving
changes in HTML Source View. It didn't happen with every Composer document
though. This is the document that I could reproduce this crash on consistently:
http://rocknroll/users/ktrina/publish/product-state-current.html

Build ID: Win32 Comm Build 2002-02-14-06-trunk
Platform: Win2k
Talkback Incident ID: 2956001

Stack Trace:
 
FrameManager::ReResolveStyleContext
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1788]
FrameManager::ReResolveStyleContext
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1932]
FrameManager::ReResolveStyleContext
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1932]
FrameManager::ReResolveStyleContext
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1932]
FrameManager::ReResolveStyleContext
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1932]
FrameManager::ReResolveStyleContext
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1932]
FrameManager::ReResolveStyleContext
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1932]
FrameManager::ComputeStyleChangeFor
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 2193]
PresShell::ReconstructStyleData
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5344]
PresShell::StyleSheetAdded
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5362]
nsDocument::InsertStyleSheetAt
[d:\builds\seamonkey\mozilla\content\base\src\nsDocument.cpp, line 1438]
CSSLoaderImpl::InsertSheetInDoc
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 1196]
CSSLoaderImpl::LoadStyleLink
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 1466]
nsStyleLinkElement::UpdateStyleSheet
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleLinkElement.cpp, line 356]
nsHTMLLinkElement::SetDocument
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLLinkElement.cpp,
line 106]
nsGenericHTMLContainerElement::InsertChildAt
[d:\builds\seamonkey\mozilla\content\html\content\src\nsGenericHTMLElement.cpp,
line 3849]
nsGenericElement::doInsertBefore
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 2292]
nsHTMLMapElement::InsertBefore
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLMapElement.cpp, line 64]
InsertElementTxn::DoTransaction
[d:\builds\seamonkey\mozilla\editor\libeditor\base\InsertElementTxn.cpp, line 115]
nsTransactionItem::DoTransaction
[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionItem.cpp, line 183]
nsTransactionManager::BeginTransaction
[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionManager.cpp, line 1078]
nsTransactionManager::DoTransaction
[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionManager.cpp, line 140]
nsEditor::Do [d:\builds\seamonkey\mozilla\editor\libeditor\base\nsEditor.cpp,
line 494]
nsEditor::InsertNode
[d:\builds\seamonkey\mozilla\editor\libeditor\base\nsEditor.cpp, line 1152]
nsHTMLEditor::ReplaceHeadContentsWithHTML
[d:\builds\seamonkey\mozilla\editor\libeditor\html\nsHTMLEditor.cpp, line 1646]
nsHTMLEditor::RebuildDocumentFromSource
[d:\builds\seamonkey\mozilla\editor\libeditor\html\nsHTMLEditor.cpp, line 1708]
nsEditorShell::RebuildDocumentFromSource
[d:\builds\seamonkey\mozilla\editor\composer\src\nsEditorShell.cpp, line 2366]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 2000]
XPC_WN_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 834]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2803]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 850]
nsXPCWrappedJSClass::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjsclass.cpp, line 1203]
nsXPCWrappedJS::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjs.cpp, line 430]
PrepareAndDispatch
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcstubs.cpp,
line 117]
SharedStub
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcstubs.cpp,
line 139]
nsControllerCommandManager::DoCommand
[d:\builds\seamonkey\mozilla\embedding\components\commandhandler\src\nsControllerCommandManager.cpp,
line 190]
nsComposerController::DoCommand
[d:\builds\seamonkey\mozilla\editor\composer\src\nsComposerController.cpp, line 240]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 2000]
XPC_WN_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 834]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2803]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 850]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 925]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3417]
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1019]
nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 182]
nsEventListenerManager::HandleEventSubType
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
1218]
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
2210]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3383]
PresShell::HandleDOMEventWithTarget
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6053]
nsButtonBoxFrame::MouseClicked
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsButtonBoxFrame.cpp, line 195]
nsButtonBoxFrame::HandleEvent
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsButtonBoxFrame.cpp, line 142]
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6022]
PresShell::HandleEventWithTarget
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5973]
nsEventStateManager::CheckForAndDispatchClick
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp, line 2465]
nsEventStateManager::PostHandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp, line 1547]
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6026]
PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5928]
nsViewManager::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 2005]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 301]
nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1844]

Comment 1

17 years ago
confirming..I also saw this at K'trina's desk...

K'trina can you tell us what you edited in that document?
what HTML code did you edit? thanks.
(Reporter)

Comment 2

17 years ago
I was just removing a <blockquote> to get rid of an unwanted space in the document.

Updated

17 years ago
Severity: normal → critical
Keywords: crash

Comment 3

16 years ago
is this still a problem?
over to editor:core for triage
Assignee: syd → glazman
Component: Editor: Composer → Editor: Core

Updated

16 years ago
Keywords: nsbeta1
Whiteboard: EDITORBASE
this bug is not in editor:core but in Layout and Style System
reassigning to David Baron for triage
Assignee: glazman → dbaron
Component: Editor: Core → Style System
(Assignee)

Updated

16 years ago
Summary: Crash when switching from HTML source to Normal view or saving changes in HTML Source View → [RR]Crash when switching from HTML source to Normal view or saving changes in HTML Source View

Comment 5

16 years ago
EDITORBASE- because EDITORBASE does not care about html view in composer
Whiteboard: EDITORBASE → EDITORBASE-
(Assignee)

Comment 6

16 years ago
I managed to reproduce this once, but then couldn't reproduce it again...
(Assignee)

Comment 7

16 years ago
Er, actually, that's because I can reproduce it on the 1.0 branch but not the trunk.
(Assignee)

Comment 8

16 years ago
No, it's actually because it's fixed by the patch on bug 141054.

*** This bug has been marked as a duplicate of 141054 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 9

16 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.