address book will NOT search for CONN without finding every CONNIE

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Maren, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160303134406

Steps to reproduce:

type in the t-bird search box: conn



Actual results:

Tbird automatically finds (in addtion to other stuff) EVERY Connie in my address book...



Expected results:

USED to be able to just add a space after conn but that no longer works in newer versions.

Comment 1

2 years ago
Giving partial matches is the expected outcome and works like this by design, right, Magnus?
Flags: needinfo?(mkmelin+mozilla)
(Reporter)

Updated

2 years ago
Whiteboard: BAD design... needs fixing...

Updated

2 years ago
Component: Search → Message Compose Window

Comment 2

2 years ago
Yes, of course. Otherwise people would have a real hard time finding anything.
If you need the space you can put the whole thing in quotes. "conn "
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(mkmelin+mozilla)
Resolution: --- → INVALID

Updated

2 years ago
Whiteboard: BAD design... needs fixing...
(Reporter)

Comment 3

2 years ago
THANK YOU. THANK YOU THANK YOU....  Quotation marks sure eliminated every Connie and Conner in 
my 8,843-contacts address book... no joke - NO exaggeration; 8,843 contacts!!!!  
I've been struggling with this ever since it was "fixed" and I just said grrrrrr back then.
THANKS again!!!

Comment 4

2 years ago
Glad it worked out for you!
You need to log in before you can comment on or make changes to this bug.