Cells rendered black with Google sheets




2 years ago
2 years ago


(Reporter: birtles, Unassigned)


({regression, regressionwindow-wanted})

47 Branch
Windows 10
regression, regressionwindow-wanted

Firefox Tracking Flags

(Not tracked)


(Whiteboard: [gfx-noted])


(2 attachments)



2 years ago
Created attachment 8732474 [details]

When using Google sheets on Developer Edition today I see large areas rendered black on certain spreadsheets. See attached screenshot (note that the *grey* areas are just confidential information I blurred out--the *black* areas are as rendered).

It doesn't happen with all spreadsheets, just some. Also, the area that is blacked out changes from time to time (e.g. when resizing the window) but is impossible to remove completely. It doesn't disappear, for example, when I select a black cell (as you can see in the screenshot).

A few items from about:support:


名前: Firefox
バージョン: 47.0a2
ビルド ID: 20160312004006
更新チャンネル: aurora
ユーザエージェント: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
OS: Windows_NT 10.0 x86
マルチプロセスウィンドウ: 0/1 (無効)
セーフモード: false


Direct2D 有効: true
DirectWrite 有効: true (10.0.10240.16430)
GPU #2 の使用: false
GPU 描画支援のウィンドウ: 1/1 Direct3D 11 (OMTC)
WebGL レンダラ: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
アダプタ RAM: Unknown
アダプタドライバ: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
アダプタ名: Intel(R) HD Graphics Family
サブシステム ID: 00000000
デバイス ID: 0x0a16
ドライバの日付: 7-17-2015
ハードウェア H264 デコーディング対応: Yes
ベンダ ID: 0x8086
非同期パン / ズーム: なし
AzureCanvasAccelerated: 0
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo



インクリメンタル GC: true


有効: true
アクセシビリティの無効化: 0


名前: Multi-process Firefox A/B Test
ID: e10s-enabled-aurora-20151020@experiments.mozilla.org
説明: Measure the effect of multi-process Firefox
アクティブ: false
終了日: 1446353215064
ブランチ: user-disabled

Let me know if you want anything translated.

Comment 1

2 years ago
Created attachment 8732475 [details]
Another screenshot

Just applied update and restarted, problem still exists.

Tried to resize window but the problem only becomes worse as evidenced in this screenshot.
Thanks for the report. Are you able to run mozregression to find what introduced this regression? And would you be able to supply a file, scrubbed of confidential information, which can reproduce this?
Flags: needinfo?(bbirtles)
Keywords: regressionwindow-wanted

Comment 3

2 years ago
(In reply to Jamie Nicol [:jnicol] from comment #2)
> Thanks for the report. Are you able to run mozregression to find what
> introduced this regression? And would you be able to supply a file, scrubbed
> of confidential information, which can reproduce this?

Possibly. This only reproduces on my home machine, and not 100% reliably so it might take some time. I'll give it a try tomorrow.
Flags: needinfo?(bbirtles)
This might be a long shot, but you should also look at about:memory and check if the memory usage is particularly high. I think that one possible side effect of running low on memory is graphics stuff going weird, and we have a number of bugs on file about high memory usage with Google Sheets (such as bug 1249739).

Comment 5

2 years ago
Sounds possible although I don't remember memory usage being particularly high on that occasion. I brought my laptop to work to try and repro and run mozregression but was unable to repro. If I hit it again, I'll check memory usage.


2 years ago
Whiteboard: [gfx-noted]

Comment 6

2 years ago
Brought my computer to try reproducing but without any luck. I'll follow up if I manage to repro again.

I have tried to reproduce this issue on the latest Nightly (48.0a1, Build ID 20160328004018) and Aurora (47.0a2, Build ID 20160328004018) and no matter how many times I resize my window, minimize or switch tabs I can't reproduce this issue. 
If you figure out how to reproduce it consistently please add steps to reproduce.

Flags: needinfo?(bbirtles)


2 years ago
Flags: needinfo?(bbirtles)
I'm closing this since the issue does not appear to be reproducible. Please reopen the bug report if the issue returns.
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.