Elements on page twitch up and down by 1 px when I scroll it to the beginning/end

RESOLVED DUPLICATE of bug 1012752

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1012752
2 years ago
2 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox48 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
>>>   My Info:   Win7_64, Nightly 48, 32bit, ID 20160319030558
STR:
1. Open https://bugzilla.mozilla.org/show_bug.cgi?id=841354
2. Click "show" link near "CC List" to expand the list of users
3. Click "edit" link near "Crash Signature" to open textarea
4.A) Open responsive design mode (Ctrl+Shift+M), select appropriate dementions for the page
4.B) Use Style editor (in separate window) to hide comments section and elements below,
     then resize the textarea from Step 3
 [!!! The goal of Step 4 is to make
  the height of the page itself about 2-10px bigger than the height of viewport for easy scrolling]
5. Scroll the page to the bottom using mouse wheel (if you're using responsive design mode,
   make sure that the rightmost scrollbar thumb always stays at the top of scrollbar area)
6. Scroll the page to the top using mouse wheel
7. Repeat Steps 5-6 several times
8. Click in textarea from Step 3 to focus it
9. Repeat Steps 5-6 several times

AR:  
 In Step 7 everything works as expected
 In Step 9 the summary, the list of users and text "Last Comment" twitch by 1px

ER:  
 In Step 9 there should be no twitching

Note:
1) I saw such twitching numerous times in markup-view (devtools), which also uses HTML elements as UI
2) I saved the page from comment 1 locally, then tried to reproduce the bug. As a result,
   different elements on the page were twitching: #moz_login and "Search" button at the top
Comment hidden (spam)
(Reporter)

Updated

2 years ago
See Also: → bug 1267885
Is this fixed in Nightly? It may have been fixed by bug 1012752.
Flags: needinfo?(arni2033)
(Reporter)

Comment 3

2 years ago
I tested 5 of ~30 web pages where I saw this bug, and it seems fixed now.

Bad:    Win7_64, Nightly 49, 32bit, ID 20160526082509 (2016-05-26)
Bad:    Win7_64, Nightly 50, 32bit, ID 20160726080520 (2016-07-26)
Good:   Win7_64, Nightly 51, 32bit, ID 20160817030202 (2016-08-17)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(arni2033)
Resolution: --- → DUPLICATE
Duplicate of bug: 1012752
(Reporter)

Updated

2 years ago
See Also: → bug 1327350
(Reporter)

Updated

2 years ago
See Also: → bug 1327901
You need to log in before you can comment on or make changes to this bug.