After user scrolls page "Options-Search" with opened dropdown menu - this dropdown is divided from box and scrolls with whole page.

RESOLVED DUPLICATE of bug 982121

Status

()

RESOLVED DUPLICATE of bug 982121
2 years ago
2 years ago

People

(Reporter: your.krosh, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8732834 [details]
options_search.mp4

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.87 Safari/537.36

Steps to reproduce:

Precon: resolution 1366*768
1. Open FF
2. Go to "Options"->Search (the page is displayed with the right scroll)
3. Click on arrow to choose my default search - drop-down menu opens
4. Scroll page via scroll button 


Actual results:

The drop-down menu scrolls with whole page
Note: this bug is also reproducible when user resize browser's window until scroll appears on the page


Expected results:

The drop-down menu should not change its place.
(Reporter)

Updated

2 years ago
Component: Untriaged → Menus
OS: Unspecified → All
Hardware: Unspecified → All

Comment 1

2 years ago
Gijs, do you know the dev who implemented about:preferences#search? I think this bug is here still this addition in about:preferences.
Component: Menus → Preferences
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to Loic from comment #1)
> Gijs, do you know the dev who implemented about:preferences#search? I think
> this bug is here still this addition in about:preferences.

--> Florian
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(florian)
This doesn't seem specific to the search pane, I can reproduce with the "When Nightly starts: Show my home page" menulist of the General pane.
Flags: needinfo?(florian)
(In reply to Florian Quèze [:florian] [:flo] from comment #3)
> This doesn't seem specific to the search pane, I can reproduce with the
> "When Nightly starts: Show my home page" menulist of the General pane.

Neil, is there something we can do about this?
Flags: needinfo?(enndeakin)
At step 4, do you mean 'scroll with the mouse wheel' rather than 'Scroll page via scroll button' as the video appears to suggest? Or is there some special scroll button on the mouse or keyboard being used?

I think mousewheel events should be ignored when a menulist is open.
Flags: needinfo?(enndeakin)

Comment 6

2 years ago
You need to use the mouse wheel.
(Reporter)

Comment 7

2 years ago
Yes, you are right. I mean 'mouse wheel'.
sorry, my mistake.
There are two bugs here:

1. Windows needs to implement a call to ShouldConsumeOnMouseWheelEvent to prevent the mousewheel from scrolling outside the popup. This is bug 982121.

2. When the mouse is inside the popup, the mousewheel event should be ignored. Likely, there is some search done to find the nearest scrollable frame, but this should break out when a menupopup frame is encountered.

Updated

2 years ago
Depends on: 982121

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1191751
I files 1258820 bug on the second issue above.

Updated

2 years ago
No longer depends on: 982121
Duplicate of bug: 982121
You need to log in before you can comment on or make changes to this bug.