Link loads, but is not followed

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: wtpooh, Assigned: don)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
When I go to www.bmj.org and click on "Four papers presented..." (top right),
nothing seems to happen, even though "Document
http://www.bmj.org/content/vol319/issue7209/#EDUCATION_AND_DEBATE loaded
successfully" shows up on my console.  Going forward and back does more strange
things, like mozilla is loading pages but forgetting to display them.  Here's my
console log along with what I actually saw:

$ sh mozilla-apprunner.sh
MOZILLA_FIVE_HOME=/home/wtpooh/rpms/package
  LD_LIBRARY_PATH=/home/wtpooh/rpms/package:/home/wtpooh/rpms/rvplayer5.0
      MOZ_PROGRAM=./apprunner
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
Profile Manager : Command Line Options : Begin
Profile Manager : Command Line Options : End
Profile Manager : Profile Wizard and Manager activites : Begin
Profile Manager : Profile Wizard and Manager activites : End
Toolbar registered as Drag Listener
Toolbar registered as Drag Listener
failed to get sidebar_pref
nsWidget::RealizeSignal(0x8105650)
Doing Startup...
Creating browser app core
BrowserAppCore has been created.
Setting content window
browser.startup.page = 1
startpage = http://www.mozillazine.org/

Recieving ... /5895=,CFC-2857.1; path=/
Document http://www.mozillazine.org/ loaded successfully
Document: Done (2.917 secs)

(now looking at mozillazine.  I type www.bmj.org into the box)

nsToolbarDragListener::MouseUp
nsToolbarDragListener::MouseUp
FindShortcut: in='www.bmj.org'  out='null'

Recieving ... JServSessionId=935717250132; domain=www.bmj.com; path=/
Document http://www.bmj.org/ loaded successfully
Document: Done (1.222 secs)

(now looking at www.bmj.org.  I click on "Four papers presented...")

Document http://www.bmj.org/content/vol319/issue7209/#EDUCATION_AND_DEBATE
loaded successfully

(still looking at www.bmj.org.  The URL box (the place you type in the url) says
"http://www.bmj.org/content/vol319/issue7209/#EDUCATION_AND_DEBATE" Note that it
never doesn't print "Document: Done".  I click on "Current Issue")


Recieving ... JServSessionId=935717398458; domain=www.bmj.com; path=/
Document http://www.bmj.org/current.shtml loaded successfully
Document: Done (2.767 secs)

(now looking at http://www.bmj.org/current.shtml, and the URL box says so.  I
click "Back")

nsToolbarDragListener::MouseUp
Going Back

Recieving ... JServSessionId=935717535009; domain=www.bmj.com; path=/
Document http://www.bmj.org/content/vol319/issue7209/#EDUCATION_AND_DEBATE
loaded successfully
Document: Done (2.525 secs)

(I am now looking at
http://www.bmj.org/content/vol319/issue7209/#EDUCATION_AND_DEBATE, which is
where I should be.  The URL box is correct.  I click "Back again")

nsToolbarDragListener::MouseUp
Going Back
Changing  URL from
http://www.bmj.org/content/vol319/issue7209/#EDUCATION_AND_DEBATE to
http://www.bmj.org/ for history entry 2
Document http://www.bmj.org/ loaded successfully

(Now the URL box says http://www.bmj.org/, but I'm really at
http://www.bmj.org/current.shtml.  I click "Back" again)

nsToolbarDragListener::MouseUp
Going Back

Recieving ... /5895=,CFC-2857.1-2858.1; path=/
Document http://www.mozillazine.org/ loaded successfully
Document: Done (2.206 secs)

(Now I am back at mozillazine, and the URL box is right.)


Running M9, build 1999082414, RedHat 5.2

Updated

19 years ago
Component: Browser-General → Networking-Core
QA Contact: leger → paulmac

Comment 1

19 years ago
paulmac, can you reproduce?

Updated

19 years ago
OS: Linux → All
Hardware: PC → All

Comment 2

19 years ago
yes, I see this on all platforms. Works OK on 4.x.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 3

19 years ago
unfortunately, this page has changed, so this bug can't be regressed. marking
works for me unless the original page can be resurrected

Comment 4

19 years ago
Bulk move of all Networking-Core (to be deleted component) bugs to new
Networking component.
You need to log in before you can comment on or make changes to this bug.