REBUG 1206278, Microphone bug still there. (Windows 10, Firefox 45.0.1, Flash 21)

RESOLVED DUPLICATE of bug 1251202

Status

()

Core
Plug-ins
--
major
RESOLVED DUPLICATE of bug 1251202
2 years ago
11 months ago

People

(Reporter: Hell Knight, Unassigned, NeedInfo)

Tracking

({64bit, flashplayer})

45 Branch
x86_64
Windows 10
64bit, flashplayer
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160315153207

Steps to reproduce:

I personally consider this bug sort of dangerous as this might blow up your speakers or even destroy your hearing.

reBUG of Bug 1206278

With Windows 10 Pro x64 Firefox 45.0.1 x64 and Flash 21, which supposedly fixed this issue, visit: http://webcammictest.com/check-microphone.html

Case 1: Click "Test Microphone" and accept.
Case 2: When you go on the audio input selection and choose a different input device.


Actual results:

Case 1: There are odd noises when you press playback and talk into mic.
Case 2: You will enjoy a very loud and horribly annoying buzz (like a hanging looped 1ms sound buffer) and the mic meter stays at 100%.


Expected results:

Expected results are obvious.

Bug 1206278 is marked as been fixed, it does not seem so: https://bugzilla.mozilla.org/show_bug.cgi?id=1206278
On Adobe's site: https://bugbase.adobe.com/index.cfm?event=bug&id=4061929

It works with Microsoft Edge, it works with Chrome.

Additional information: I use a USB Microphone.
(Reporter)

Updated

2 years ago
Severity: normal → major
Keywords: 64bit, flashplayer
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Summary: REBUG 1206278, Microphone bug still there. (Firefox 45.0.1/Flash 21) → REBUG 1206278, Microphone bug still there. (Windows 10, Firefox 45.0.1, Flash 21)

Updated

2 years ago
Component: Untriaged → Plug-ins
Product: Firefox → Core

Comment 1

a year ago
Stefan, could you do some exploratory testing with this? I assume this is an Adobe bug, but we'd like to give them the most precise STR possible, including whether this depends on hardware config etc.
Flags: needinfo?(stefan.georgiev)
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Shockwave Flash 24.0.0.186

I have tested this issue on latest FF release (50.0.2) and latest Nightly build and could not reproduce it. I have used Microsoft LifeChat LX-3000 head set in order to reproduce it but without success. 

Hell Knight, can you still reproduce this issue on the latest Nightly build and updated Flash ?
Flags: needinfo?(stefan.georgiev) → needinfo?(helldamn)

Updated

11 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1251202
You need to log in before you can comment on or make changes to this bug.