If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mailnews crashed when saving an attachment [@ nsMessenger::SaveAttachment]

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
critical
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Ashley Bischoff (blog at handcoding.com), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020214
BuildID:    2002021403

I went to save an attachment in MailNews, and it crashed.

Reproducible: Couldn't Reproduce
Steps to Reproduce:
1. I had MailNews open
2. I was viewing a message in the preview pane
3. I right-clicked on the attachment and chose "Save As"
4. The Save dialog-box popped up for a moment, but then Mozilla crashed

Actual Results:  Mozilla crashed

Expected Results:  No crash :)

Talkback ID: TB2976261M
CC: stephend@netscape.com for talkback retrieval, please (TB2976261M).
Keywords: crash
0x645f38a0
scorillont.dll + 0x38cf (0x100038cf)
SHLWAPI.DLL + 0x20dbc (0x70bf0dbc)
SHELL32.dll + 0x110a1 (0x783010a1)
SHELL32.dll + 0x110d9 (0x783010d9)
SHELL32.dll + 0x11331 (0x78301331)
SHELL32.dll + 0x16159 (0x78306159)
comdlg32.dll + 0x24b5f (0x76b54b5f)
comdlg32.dll + 0x2723a (0x76b5723a)
comdlg32.dll + 0x273ac (0x76b573ac)
comdlg32.dll + 0x5995 (0x76b35995)
USER32.DLL + 0x2e98 (0x77e12e98)
USER32.DLL + 0x11a8c (0x77e21a8c)
USER32.DLL + 0x395f (0x77e1395f)
ntdll.dll + 0x2032f (0x77fa032f)
USER32.DLL + 0x1b248 (0x77e2b248)
USER32.DLL + 0x19323 (0x77e29323)
USER32.DLL + 0xfe7e (0x77e1fe7e)
USER32.DLL + 0x2e98 (0x77e12e98)
USER32.DLL + 0x6a72 (0x77e16a72)
USER32.DLL + 0x6b0b (0x77e16b0b)
COMCTL32.DLL + 0x4803 (0x71784803)
COMCTL32.DLL + 0x4722 (0x71784722)
COMCTL32.DLL + 0x47e1 (0x717847e1)
COMCTL32.DLL + 0x28401 (0x717a8401)
COMCTL32.DLL + 0x4722 (0x71784722)
COMCTL32.DLL + 0x4642 (0x71784642)
USER32.DLL + 0x2e98 (0x77e12e98)
USER32.DLL + 0x30e0 (0x77e130e0)
USER32.DLL + 0x320f (0x77e1320f)
USER32.DLL + 0xe3a6 (0x77e1e3a6)
USER32.DLL + 0xe215 (0x77e1e215)
USER32.DLL + 0xe4bb (0x77e1e4bb)
USER32.DLL + 0x28036 (0x77e38036)
comdlg32.dll + 0x72c7 (0x76b372c7)
comdlg32.dll + 0x56a8 (0x76b356a8)
comdlg32.dll + 0x5290 (0x76b35290)
comdlg32.dll + 0x569a (0x76b3569a)
nsMessenger::SaveAttachment
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMessenger.cpp, line 761]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 2000]
XPC_WN_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 834]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2803]
js_Execute [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 1014]
obj_eval [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 1033]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 834]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2803]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 850]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2803]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 850]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 925]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3417]
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1019]
nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 182]
nsEventListenerManager::HandleEventSubType
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
1218]
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
2210]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3383]
PresShell::HandleDOMEventWithTarget
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6053]
nsMenuFrame::Execute
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuFrame.cpp, line 1627]
nsMenuFrame::HandleEvent
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuFrame.cpp, line 460]
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6022]
PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5928]
nsViewManager::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 2005]
Summary: Mailnews crashed when saving an attachment (TB2976261M) → Mailnews crashed when saving an attachment [@ nsMessenger::SaveAttachment]

Updated

16 years ago
QA Contact: esther → trix

Comment 3

16 years ago
Alex, can you still reproduce this (with the same attachment, possibly), in a
nightly build?

We need more data.  Perhaps you can attach your attachment here, or forward it
as-is to my crash-gathering-email hbw@chello.se?
Håkan: I can't reproduce the crash anymore. Is the talkback data non-helpful?

-> WFM?

Comment 5

16 years ago
If you can't reproduce, and we don't have a testcase, it's wfm.  Thanks for
replying.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 6

16 years ago
verified worksforme using latest trunk build 2002040903
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
Crash Signature: [@ nsMessenger::SaveAttachment]
You need to log in before you can comment on or make changes to this bug.