Linux Firefox "new window" creates unusable tiny window

RESOLVED INCOMPLETE

Status

()

Core
Widget: Gtk
RESOLVED INCOMPLETE
2 years ago
2 years ago

People

(Reporter: Ed Braaten, Unassigned)

Tracking

45 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.87 Safari/537.36

Steps to reproduce:

Open Firefox.  If window is maximized, un-maximize will produce a tiny, unusable window that can be resized to a usable window.  Close Firefox.  Re-open Firefox and it will open in a tiny, unusable window - it does not remember the last re-sized settings of the un-maximized window.  Alternately, open Firefox and use the "File, New Window" option to create a new browser window - it will create a tiny, unusable window that has to be re-sized.   Environment is Linux Fedora 23 Workstation Edition.


Actual results:

Un-maximized window default size is too small.  Size of last closed un-maximized windows are not saved and re-used upon new, un-maximized window creation.


Expected results:

Firefox should be remembering the last un-minimized window size settings.  Firefox should have a larger default un-minimized window size upon first startup.
(Reporter)

Comment 1

2 years ago
Created attachment 8733112 [details]
Screenshot-LinuxFirefox45.0.1-un-minimized-new-window.png

This is a screenshot of the tiny, unusable window that "File, new window" creates.
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 2

2 years ago
After some more research, I noticed that the "verified fixed" bug 429954 from 2008 for the Mac OS X platform has a very similar description to this new issue on the Linux Fedora platform.
Hello Ed,
The user agent you posted is a Chrome user agent and not a Firefox one.

I tried to reproduce the reported issue on versions on FF45/48 with no luck:
45.0.1Build ID 20160315153207 Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 
48.0a1 Build ID 20160324030447 User Agent Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 

My Fedora version is: 
Linux P5099 4.2.3-300.fc23.x86_64 #1 SMP Mon Oct 5 15:42:54 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

I also tried to reproduce the issue you mentioned with the Google Chrome browser, the same version you have posted the user agent from in the report and still no luck.

Please attach the correct user agent for the Firefox browser you use and confirm that this is indeed a Firefox issue.
Flags: needinfo?(ed)
(Reporter)

Comment 4

2 years ago
Adrian,

Yes, I used my Chrome browser client when I posted the bug.  This issue is not happening with Chrome or any other app on my system. The user agent string from my Firefox browser which is still experiencing this "tiny window" issue is:  Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0.

The "uname -a" from my Fedora system:  Linux sidekick 4.5.0 #18 SMP Wed Mar 16 17:29:05 PDT 2016 x86_64 x86_64 x86_64 GNU/Linux
Flags: needinfo?(ed)

Updated

2 years ago
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
(Reporter)

Comment 5

2 years ago
Now, about a month after I filed this bug, the problem simply vanished!  Now, a "normal" size window opens up and Firefox seems to be remembering the last known size/position.  I've installed many Fedora updates, the Vivaldi browser, upgraded the kernel, etc. during the past few weeks.  I don't know at this point what change influenced the return of normal behavior to Firefox.
Usually Firefox uses the size of the last focused window, or something like that.
Not sure the exact algorithm, but sounds like it wasn't working well.
Based on the current information we have available here I don't think we have enough to take any action. Ed, I shall resolve bug as incomplete for the moment but would you please be kind enough to reopen it if you encounter the bug again or if you get anything to help reproduce it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.