Layout corrupted when switching from lodpi to hidpi

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: birtles, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox48 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8733277 [details]
Corrupted layout screenshot

Sorry I can't provide a better STR, but I *think* what I did was as follows:

1. Connect hidpi laptop to TV (lower DPI than laptop screen)
(Laptop decides to go to second-screen only mode so going hi-dpi -> low-dpi)
2. Switch laptop to extended display mode (i.e. not mirroring, but laptop is primary screen)
(i.e. going back to high dpi)
3. Look at contents in firefox

The result is shown in the attached screenshot. It's odd. It's almost as if some parts of layout are using the full extended screen width as the ratio for spacing frames?

Sorry this isn't a more useful bug report but perhaps it might help fill out some of the picture if there are other related bug reports.
Huh, that's a weird one. Can you reproduce it, or was it a "one-off"?

Did it resolve itself on any particular action, such as reloading the page, resizing the browser window, etc.?

Was this with latest Nightly, I guess? Or else what version?
(Reporter)

Comment 2

3 years ago
(In reply to Jonathan Kew (:jfkthame) from comment #1)
> Huh, that's a weird one. Can you reproduce it, or was it a "one-off"?

I've only seen in that one time but it happened on several tabs. I haven't tried the same sequence of steps but can do so if needed.

> Did it resolve itself on any particular action, such as reloading the page,
> resizing the browser window, etc.?

Reloading the page fixed it.

> Was this with latest Nightly, I guess? Or else what version?

Yes. Yesterday's nightly.
Could you please try to repeat your steps and see if this is consistently reproducible? I tried to emulate a similar scenario (with slightly different hardware on hand), but so far I haven't seen it. If we can confirm an exact setup & steps that makes it happen, that would be really helpful.
Flags: needinfo?(bbirtles)
(Reporter)

Comment 4

3 years ago
(In reply to Jonathan Kew (:jfkthame) from comment #3)
> Could you please try to repeat your steps and see if this is consistently
> reproducible? I tried to emulate a similar scenario (with slightly different
> hardware on hand), but so far I haven't seen it. If we can confirm an exact
> setup & steps that makes it happen, that would be really helpful.

Yeah, I'm afraid I haven't been able to reproduce it. I've seen plenty of other dpi-change bugs (roughly ~50% of the time when disconnecting from a lo-dpi screen Firefox fails to update the chrome until I restart it)--but I haven't been unable to reproduce this particular one yet. I'll make a note to try again next week though.
Flags: needinfo?(bbirtles)
(In reply to Brian Birtles (:birtles) from comment #4)
> (In reply to Jonathan Kew (:jfkthame) from comment #3)
> > Could you please try to repeat your steps and see if this is consistently
> > reproducible? I tried to emulate a similar scenario (with slightly different
> > hardware on hand), but so far I haven't seen it. If we can confirm an exact
> > setup & steps that makes it happen, that would be really helpful.
> 
> Yeah, I'm afraid I haven't been able to reproduce it. I've seen plenty of
> other dpi-change bugs (roughly ~50% of the time when disconnecting from a
> lo-dpi screen Firefox fails to update the chrome until I restart it)--but I
> haven't been unable to reproduce this particular one yet. I'll make a note
> to try again next week though.

Thanks.

(The other issue you mention could be the same as bug 1254020, for which a patch just landed. If it doesn't go away once you're on a Nightly with that fix, please follow up.)

Comment 6

2 years ago
Please reopen if you're still seeing this.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.